summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-06-17 23:02:51 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-17 23:21:09 +0300
commitb0dbcfe9c852306f2a639d50a9d5b11eb71de9ec (patch)
treec32c7cab7f299d44d3ae45b1537199b4bdf94fcd /media-sound/pavucontrol-qt
parentdev-util/lxqt-build-tools: drop 2.0.0 (diff)
downloadgentoo-b0dbcfe9c852306f2a639d50a9d5b11eb71de9ec.tar.gz
gentoo-b0dbcfe9c852306f2a639d50a9d5b11eb71de9ec.tar.bz2
gentoo-b0dbcfe9c852306f2a639d50a9d5b11eb71de9ec.zip
media-sound/pavucontrol-qt: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-sound/pavucontrol-qt')
-rw-r--r--media-sound/pavucontrol-qt/Manifest1
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-2.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/Manifest b/media-sound/pavucontrol-qt/Manifest
index 5218e736397d..c171f9dad157 100644
--- a/media-sound/pavucontrol-qt/Manifest
+++ b/media-sound/pavucontrol-qt/Manifest
@@ -1,2 +1,3 @@
DIST pavucontrol-qt-1.3.0.tar.xz 107612 BLAKE2B 1b3453d3622247adfbc69cc76cc267567bd7d6d8779a7b46b116d204cd29852acf06359f5a258e3d964bc4564ce8b490a527ae61fa6357793410887ac3616403 SHA512 64f954b103b6ffbb97a81a23489799a1fff71810f15f755b92e814a03d8bbe6351ba2a1c8179d60777cbbe60e5ee40cf0e04167cf1467a5b27c9b02142f7cb8c
DIST pavucontrol-qt-1.4.0.tar.xz 111712 BLAKE2B c3329a621dda082c63e7ba9d289476932170b6bb569e7b508d9158bbe31f20933a70047eb69e69d768ff48ea5ed27a8ddfdcae2c4bedee6b0b73484488f1d2f6 SHA512 cfa878bddd0b0299319c31a4e97aa8b6dc799f040fedf5ca0210d8eeb526f59258aab57ae050987633826c7a94fbbd0e1a1b1fc184fc8693541c799b6118a157
+DIST pavucontrol-qt-2.0.0.tar.xz 114044 BLAKE2B ccfe5de71e516a05ccf151d59832d8e7e7e44000a34f352945092129766b80d39ceead7b33f2caf9ad6f5becf32e0df82fe5f7379cf98355c0d3f303f7ef88cb SHA512 e2c08c9413cfade402fc84d06b5f631a7c25b4b47d20da28099fdbe6cd6cc485ae5c855c6da0d5077bdac404b08ac90e4ef0ec907c1ae49ffb3a758f329bd63f
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-2.0.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-2.0.0.ebuild
new file mode 100644
index 000000000000..321e67325844
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ media-libs/libpulse[glib]
+"
+RDEPEND="${DEPEND}"