summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-04-18 10:57:35 +0200
committerJohannes Huber <johu@gentoo.org>2020-04-18 10:58:17 +0200
commite10585731d3949b59123192e681c9dbf285c4d60 (patch)
tree7707cda85615a470848f23ee7acbab25b53cf6fd /media-sound/lollypop
parentapp-backup/rdiff-backup: Remove old (diff)
downloadgentoo-e10585731d3949b59123192e681c9dbf285c4d60.tar.gz
gentoo-e10585731d3949b59123192e681c9dbf285c4d60.tar.bz2
gentoo-e10585731d3949b59123192e681c9dbf285c4d60.zip
media-sound/lollypop: Version bump 1.2.35
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.35.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index c719ca5583c7..38b297f0c68e 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
DIST lollypop-1.2.34.tar.xz 509768 BLAKE2B 7f1daaa5c4906a947f4ff45d9f961fe129277c3829744321436289cea1958e9aee0a9ece610a7e9a55c06526395a0208fe8a12762e50cc9bdc3a3b0362aca931 SHA512 dc0420984efb859279e6cfb3b8967a30a5b5ff124c990ad73951b6f47cb1a34dde2bb54667b321e3609c3e13233c9efda02caa9920b00e48de123a553d885114
+DIST lollypop-1.2.35.tar.xz 509916 BLAKE2B 8cf9ea74287b6ac7d4942c2312cc4d6e07d4748d505cc9e45a896129f9e4a43ef5c65c0c18764597d7ce3c4d2fc93804c501f68ea3b67625e200497613077af6 SHA512 179fa5e77482db35de9e30e392e6d07bb5c832d5d1decaee06982570bdcbb809dc99375eeb6fe3dce75829af3570953ce517e3b4eaabceac807b9d5c382bd53e
diff --git a/media-sound/lollypop/lollypop-1.2.35.ebuild b/media-sound/lollypop/lollypop-1.2.35.ebuild
new file mode 100644
index 000000000000..06db306eb32f
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.35.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo(+)]
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pkgconfig[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_MULTI_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}