summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-05 19:18:19 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-05 19:18:19 +0200
commitae3d4df0f6111f6b7c134bef67bbaf1c9c827ca1 (patch)
tree9c45e5d1a908762f639d8a0f95ed1051f4a78106 /media-radio
parentapp-crypt/osslsigncode: drop 2.0 (diff)
downloadgentoo-ae3d4df0f6111f6b7c134bef67bbaf1c9c827ca1.tar.gz
gentoo-ae3d4df0f6111f6b7c134bef67bbaf1c9c827ca1.tar.bz2
gentoo-ae3d4df0f6111f6b7c134bef67bbaf1c9c827ca1.zip
media-radio/tqsl: add 2.7.3
Closes: https://bugs.gentoo.org/707442 Closes: https://bugs.gentoo.org/716256 Closes: https://bugs.gentoo.org/769599 Closes: https://bugs.gentoo.org/802243 Closes: https://bugs.gentoo.org/889286 Closes: https://bugs.gentoo.org/917638 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tqsl/Manifest1
-rw-r--r--media-radio/tqsl/tqsl-2.7.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-radio/tqsl/Manifest b/media-radio/tqsl/Manifest
index e471e1dbe381..870c1c637af0 100644
--- a/media-radio/tqsl/Manifest
+++ b/media-radio/tqsl/Manifest
@@ -1,2 +1,3 @@
DIST tqsl-2.6.4.tar.gz 3517633 BLAKE2B 9c43ba01186a1a2396b223a33797377735d48e020ddee879232f3bf4bcce9cbec89dfd71aea5422a353a3908f38ce9c3f3619725677612c911bf19278d1740fa SHA512 0a0f94ae95f91280ea03a35007bfa4e278f17a98496f4cfb25a841d2f519a92d7820e1a4f48394ba6caf1e99d4bcafdf4686a6b0f85ddc3640f936c58b907a1e
DIST tqsl-2.6.5.tar.gz 3521069 BLAKE2B dd2d6e366b162a6de8b78d8bdde5efcde26cee0b5c934a0615cfbb9e77cf8bd2265c928c329543f6bbeeaee9608f8fa15ba8ac06edef2be805bf79abbd459555 SHA512 2a4602b827448756e033122c0359651a230fe3122f92ae3ce72c6ed6bb1b1fd6b15804676cca1fef19dd09df6548387772721cc64a4423d8a766b7d27a38e049
+DIST tqsl-2.7.3.tar.gz 3911547 BLAKE2B e32f9b18973f1c2445b97e050e4f2c838542cfb4a0312205d2d66cf6df4db5b1e110f62782138f36dd195f43cddc3f0fb32e1a464c0695849640d04a08306464 SHA512 302db650dc0f9fcd495fd1e7abe21dcfffc167d1686b276ae0fcbb53bf5eedbc91a797d1a79d8da5bb4384d937c6b66ad44a0355a00ff014de4257c0be84ef74
diff --git a/media-radio/tqsl/tqsl-2.7.3.ebuild b/media-radio/tqsl/tqsl-2.7.3.ebuild
new file mode 100644
index 000000000000..fac65b432b32
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="https://www.arrl.org/tqsl-download"
+SRC_URI="https://www.arrl.org/${PN}/${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-db/sqlite:3=
+ dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:${WX_GTK_VER}="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html/. )
+
+src_configure() {
+ setup-wxwidgets
+ cmake_src_configure
+}