summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 19:53:06 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-02 19:53:51 +0200
commitd4a283d7069c7204e6b6b1bbc608c663deb8ec02 (patch)
tree5662bb927f87481d3b37993ee6c2804ddaf403bc /media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild
parentmedia-plugins/vdr-suspendoutput: missing die fixed (diff)
downloadgentoo-d4a283d7069c7204e6b6b1bbc608c663deb8ec02.tar.gz
gentoo-d4a283d7069c7204e6b6b1bbc608c663deb8ec02.tar.bz2
gentoo-d4a283d7069c7204e6b6b1bbc608c663deb8ec02.zip
media-plugins/vdr-systeminfo: gcc-11 reladet fix
Closes: https://bugs.gentoo.org/787707 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild')
-rw-r--r--media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..9d09ab352892
--- /dev/null
+++ b/media-plugins/vdr-systeminfo/vdr-systeminfo-0.1.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: systeminfo"
+HOMEPAGE="http://firefly.vdr-developer.org/systeminfo/"
+SRC_URI="http://firefly.vdr-developer.org/systeminfo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2"
+
+RDEPEND="sys-apps/lm-sensors
+ app-admin/hddtemp"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # Makefile correction, .eclass fails in some Makefiles
+ sed -e "s:(VDRINCDIR):(VDRDIR)/include:" -i Makefile || die
+
+ # 787707
+ eapply "${FILESDIR}/${P}_gcc11.patch"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/systeminfo/
+ insopts -m0755
+ doins "${FILESDIR}"/systeminfo.sh
+}