summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gst-plugins-gconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gst-plugins-gconf')
-rw-r--r--media-plugins/gst-plugins-gconf/Manifest1
-rw-r--r--media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31-r1.ebuild46
-rw-r--r--media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31.ebuild40
-rw-r--r--media-plugins/gst-plugins-gconf/metadata.xml14
4 files changed, 101 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gconf/Manifest b/media-plugins/gst-plugins-gconf/Manifest
new file mode 100644
index 000000000000..4a7a8f4cad54
--- /dev/null
+++ b/media-plugins/gst-plugins-gconf/Manifest
@@ -0,0 +1 @@
+DIST gst-plugins-good-0.10.31.tar.xz 2738016 SHA256 77a8436a7c0a15f876bad29616835046890df2bcaf72da02151bd91e3d292b64 SHA512 d153dcd5bb846450e9d76fe247f2b2e627e760feaad1bfd4c503a39af2128fad3630788463ea0d50539209236c864df0b2172ab9dac52f49cadff69ac7346809 WHIRLPOOL 952f65219d9e9645c9ab89b071c56d783e2c795fadbf59176e430ba86a5fcaeb6bfc93f0978d424158550a4526145b5567acf2ff1d59e0068241821d332fd3c9
diff --git a/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31-r1.ebuild b/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31-r1.ebuild
new file mode 100644
index 000000000000..511220c5e5c4
--- /dev/null
+++ b/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-good
+inherit gnome2-utils gstreamer
+
+DESCRIPTION="GStreamer plugin for wrapping GConf audio/video settings"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2.32.4-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gconf gconftool"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ --disable-schemas-install
+}
+
+multilib_src_compile() {
+ gstreamer_multilib_src_compile
+
+ if multilib_is_native_abi; then
+ emake -C gconf
+ fi
+}
+
+multilib_src_install() {
+ gstreamer_multilib_src_install
+
+ if multilib_is_native_abi; then
+ emake -C gconf DESTDIR="${D}" install
+ fi
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
diff --git a/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31.ebuild b/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31.ebuild
new file mode 100644
index 000000000000..5f81ad568c05
--- /dev/null
+++ b/media-plugins/gst-plugins-gconf/gst-plugins-gconf-0.10.31.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit gnome2-utils gst-plugins-good gst-plugins10
+
+DESCRIPTION="GStreamer plugin for wrapping GConf audio/video settings"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gconf gconftool"
+
+src_configure() {
+ gst-plugins10_src_configure --disable-schemas-install
+}
+
+src_compile() {
+ gst-plugins10_src_compile
+ cd "${S}"/gconf
+ default
+}
+
+src_install() {
+ gst-plugins10_src_install
+ cd "${S}"/gconf
+ default
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
diff --git a/media-plugins/gst-plugins-gconf/metadata.xml b/media-plugins/gst-plugins-gconf/metadata.xml
new file mode 100644
index 000000000000..4cb144fa4e13
--- /dev/null
+++ b/media-plugins/gst-plugins-gconf/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+<longdescription lang="en">
+ GStreamer plugin wrapping the GStreamer/GConf audio/video output settings
+
+ Includes the following elements:
+ * gconfaudiosrc - Audio source embedding the GConf-settings for audio input
+ * gconfaudiosink - Audio sink embedding the GConf-settings for audio output
+ * gconfvideosrc - Video source embedding the GConf-settings for video input
+ * gconfvideosink - Video sink embedding the GConf-settings for video output
+</longdescription>
+</pkgmetadata>