summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-01-24 21:38:21 +0100
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:29 +0300
commit5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d (patch)
treecdd57168efdd0079ba10a506ef883bffc6eec65f /media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild
parentdev-util/ruff: new package, add 0.3.5 (diff)
downloadgentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.gz
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.bz2
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.zip
media-libs/gstreamer: add 1.22.10, drop 1.22.3 (security)
- eclass / gst-plugins-good: Add "soup" option in the special cases - gst-plugins-good: Backport fix against tests being enabled on libsoup presence automagic-style <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6058> Closes: https://bugs.gentoo.org/836163 Closes: https://bugs.gentoo.org/908978 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild')
-rw-r--r--media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild b/media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild
new file mode 100644
index 000000000000..01b40cff235a
--- /dev/null
+++ b/media-plugins/gst-plugins-amr/gst-plugins-amr-1.22.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-ugly
+
+inherit gstreamer-meson
+
+DESCRIPTION="AMRNB encoder/decoder and AMRWB decoder plugin for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=media-libs/opencore-amr-0.1.3-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_ENABLED="amrnb amrwbdec"
+GST_PLUGINS_BUILD_DIR="amrnb amrwbdec"