summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-07-30 23:00:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-07-30 23:00:27 +0100
commit83c14b46f1b562da994100ad01bf7ed124bb2891 (patch)
treeecf708e123b808f7ce656f497ca3da296e9a36cb /media-libs
parentdev-libs/kdsingleapplication: Fix IUSE doc/examples cmake args (diff)
downloadgentoo-83c14b46f1b562da994100ad01bf7ed124bb2891.tar.gz
gentoo-83c14b46f1b562da994100ad01bf7ed124bb2891.tar.bz2
gentoo-83c14b46f1b562da994100ad01bf7ed124bb2891.zip
media-libs/libv4l: Allow Qt5 to be chosen over Qt6
Blocking Qt6 was too disruptive. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libv4l/libv4l-1.28.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-libs/libv4l/libv4l-1.28.1.ebuild b/media-libs/libv4l/libv4l-1.28.1.ebuild
index 4a917d98578e..7f11f9769139 100644
--- a/media-libs/libv4l/libv4l-1.28.1.ebuild
+++ b/media-libs/libv4l/libv4l-1.28.1.ebuild
@@ -39,7 +39,6 @@ RDEPEND="
virtual/opengl
)
!qt6? ( qt5? (
- !dev-qt/qtbase:6
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5[-gles2-only(-),-gles2(-)]
@@ -89,6 +88,11 @@ pkg_setup() {
CONFIG_CHECK="~SHMEM" linux-info_pkg_setup
}
+src_prepare() {
+ default
+ use qt6 || sed -i "/^dep_qt6/s/'qt6/&DiSaBlEd/" meson.build || die
+}
+
multilib_src_configure() {
local emesonargs=(
$(meson_native_use_feature bpf)