summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Javier Félix <web@inode64.com>2021-10-18 08:57:28 +0200
committerSam James <sam@gentoo.org>2021-10-31 03:39:32 +0000
commit647a8643d2941d4f20a6cb2b4799fc35bbc26c36 (patch)
treeea25ce1a5a1af393d382f5c40853995c1f38fc5a /media-libs
parentnet-misc/stuntman: 1.2.16 (diff)
downloadgentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.gz
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.tar.bz2
gentoo-647a8643d2941d4f20a6cb2b4799fc35bbc26c36.zip
media-libs/dav1d: fix build, support xxhash
* Require minimum nasm 2.15.05 * Disable test by default * Fix build, see bug https://code.videolan.org/videolan/dav1d/-/issues/370 and patch https://code.videolan.org/videolan/dav1d/-/commit/c6a08b3aa1ee99dade53e5e32033bc1d14455a22 the same problem with versions of gcc 10.3.0 and gcc 11.2.0, from dav1d 0.8.2 to 0.9.2. Closes: https://bugs.gentoo.org/738726 Closes: https://bugs.gentoo.org/791544 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: INODE64 <ffelix@inode64.com> Closes: https://github.com/gentoo/gentoo/pull/22621 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dav1d/dav1d-0.8.2.ebuild12
-rw-r--r--media-libs/dav1d/dav1d-0.9.0.ebuild12
-rw-r--r--media-libs/dav1d/dav1d-0.9.1.ebuild12
-rw-r--r--media-libs/dav1d/dav1d-0.9.2.ebuild12
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild11
-rw-r--r--media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch32
-rw-r--r--media-libs/dav1d/metadata.xml1
7 files changed, 77 insertions, 15 deletions
diff --git a/media-libs/dav1d/dav1d-0.8.2.ebuild b/media-libs/dav1d/dav1d-0.8.2.ebuild
index 69f483748337..caaf9cb8784f 100644
--- a/media-libs/dav1d/dav1d-0.8.2.ebuild
+++ b/media-libs/dav1d/dav1d-0.8.2.ebuild
@@ -19,15 +19,19 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
+PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
multilib_src_configure() {
local -a bits=()
@@ -44,6 +48,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-0.9.0.ebuild b/media-libs/dav1d/dav1d-0.9.0.ebuild
index ae26cc566f30..f111b62346ef 100644
--- a/media-libs/dav1d/dav1d-0.9.0.ebuild
+++ b/media-libs/dav1d/dav1d-0.9.0.ebuild
@@ -19,15 +19,19 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
+PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
multilib_src_configure() {
local -a bits=()
@@ -44,6 +48,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-0.9.1.ebuild b/media-libs/dav1d/dav1d-0.9.1.ebuild
index 7dedeea1b795..f7ae3e3273bf 100644
--- a/media-libs/dav1d/dav1d-0.9.1.ebuild
+++ b/media-libs/dav1d/dav1d-0.9.1.ebuild
@@ -19,15 +19,19 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
+PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
multilib_src_configure() {
local -a bits=()
@@ -44,6 +48,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-0.9.2.ebuild b/media-libs/dav1d/dav1d-0.9.2.ebuild
index 850f1843db9a..fb91a0e8cc7d 100644
--- a/media-libs/dav1d/dav1d-0.9.2.ebuild
+++ b/media-libs/dav1d/dav1d-0.9.2.ebuild
@@ -19,15 +19,19 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
+PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
multilib_src_configure() {
local -a bits=()
@@ -44,6 +48,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index 850f1843db9a..c0d92e63904d 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -19,13 +19,16 @@ HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
SLOT="0/5"
-IUSE="+8bit +10bit +asm"
+IUSE="+8bit +10bit +asm test xxhash"
+RESTRICT="!test? ( test )"
-ASM_DEPEND=">=dev-lang/nasm-2.14.02"
+ASM_DEPEND=">=dev-lang/nasm-2.15.05"
BDEPEND="asm? (
abi_x86_32? ( ${ASM_DEPEND} )
abi_x86_64? ( ${ASM_DEPEND} )
- )"
+ )
+ xxhash? ( dev-libs/xxhash )
+ "
DOCS=( README.md doc/PATENTS THANKS.md )
@@ -44,6 +47,8 @@ multilib_src_configure() {
local emesonargs=(
-D bitdepths=$(IFS=,; echo "${bits[*]}")
-D enable_asm=${enable_asm}
+ -D enable_tests=$(usex test true false)
+ -D xxhash_muxer=$(usex xxhash enabled disabled)
)
meson_src_configure
}
diff --git a/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch b/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch
new file mode 100644
index 000000000000..8a9b1e86eff9
--- /dev/null
+++ b/media-libs/dav1d/files/build-avoid-meson-s-symbols_have_underscore_prefix.patch
@@ -0,0 +1,32 @@
+From c6a08b3aa1ee99dade53e5e32033bc1d14455a22 Mon Sep 17 00:00:00 2001
+From: Janne Grunau <janne-vlc@jannau.net>
+Date: Tue, 21 Sep 2021 09:30:14 +0200
+Subject: [PATCH 1/5] build: avoid meson's symbols_have_underscore_prefix
+
+Meson's dynamic check is unreliable when additional compiler flags are
+passed via CFLAGS. For example '-fprofile-instr-generate' in oss-fuzz'
+coverage build. Fixes #370.
+---
+ meson.build | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 1bf69ab..1a7c409 100644
+--- a/meson.build
++++ b/meson.build
+@@ -382,7 +382,11 @@ endif
+
+ cdata.set10('ARCH_PPC64LE', host_machine.cpu() == 'ppc64le')
+
+-if cc.symbols_have_underscore_prefix()
++# meson's cc.symbols_have_underscore_prefix() is unfortunately unrelieably
++# when additional flags like '-fprofile-instr-generate' are passed via CFLAGS
++# see following meson issue https://github.com/mesonbuild/meson/issues/5482
++if (host_machine.system() == 'darwin' or
++ (host_machine.system() == 'windows' and host_machine.cpu_family() == 'x86'))
+ cdata.set10('PREFIX', true)
+ cdata_asm.set10('PREFIX', true)
+ endif
+--
+2.32.0
+
diff --git a/media-libs/dav1d/metadata.xml b/media-libs/dav1d/metadata.xml
index edef4df0c989..fbe7f555d99a 100644
--- a/media-libs/dav1d/metadata.xml
+++ b/media-libs/dav1d/metadata.xml
@@ -8,6 +8,7 @@
<flag name="8bit">Add support for decoding 8-bit AV1.</flag>
<flag name="10bit">Add support for building 10-bit and 12-bit AV1.</flag>
<flag name="asm">Enable custom assembly for faster decoding.</flag>
+ <flag name="xxhash">Enable <pkg>dev-libs/xxhash</pkg> support for hashing muxer</flag>
</use>
<upstream>
<bugs-to>https://code.videolan.org/videolan/dav1d/issues</bugs-to>