summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2025-01-02 23:26:25 +0100
committerYixun Lan <dlan@gentoo.org>2025-01-03 01:16:08 +0000
commit25c6fc40b1ceeb8767813787813a0eb66c032849 (patch)
tree4a29f84ef37095dd45d983155ed8e898ba58277a /media-libs
parentsys-devel/bc: add 1.08.0 (diff)
downloadgentoo-25c6fc40b1ceeb8767813787813a0eb66c032849.tar.gz
gentoo-25c6fc40b1ceeb8767813787813a0eb66c032849.tar.bz2
gentoo-25c6fc40b1ceeb8767813787813a0eb66c032849.zip
media-libs/tg_owt: Bump to 0_pre20241202
This should relieve some build issues with clang/libstdcxx (not clang/libc++). No real interesting changes otherwise... Bug: https://bugs.gentoo.org/924323 Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tg_owt/Manifest1
-rw-r--r--media-libs/tg_owt/tg_owt-0_pre20241202.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/media-libs/tg_owt/Manifest b/media-libs/tg_owt/Manifest
index 4662aea91114..96852491ff0b 100644
--- a/media-libs/tg_owt/Manifest
+++ b/media-libs/tg_owt/Manifest
@@ -2,3 +2,4 @@ DIST libsrtp-a566a9cfcd619e8327784aa7cff4a1276dc1e895.tar.gz 636836 BLAKE2B 496a
DIST libyuv-04821d1e7d60845525e8db55c7bcd41ef5be9406.tar.bz2 418856 BLAKE2B a72e1f75491785b272b0ded46368a67aadb643278e5764d16dcd902ab7e4139d8664ffbacd940f30113ce3171e0b0846fe0d6111ced17c5b08f326cd61b2af14 SHA512 ff9cfbb61a1361e959740d00c741dc6fbe71ca7c61770abc35f70aada402df3884d7d5992ae79472dfe3d7641154d4f13065593fee41bf8eae924e26cc654117
DIST tg_owt-0_pre20230921.tar.gz 13726037 BLAKE2B 635342dd2127330542374e2f0f9acee91844c3c825fe4610dabe2996c541d9b3dc1681999910e5b591752f7e8f65a089c16b43216dd0c0b84f1a0e913e5a0213 SHA512 538d713e9ac91e9f676cdf301d11d7b5be0d67bda6283537e03b6322f3cca5c0234ff2f2b0b23e9046709f77ed282fc4d3526d3b21ee93478c50380be410372f
DIST tg_owt-0_pre20240804.tar.gz 11722734 BLAKE2B 084bedf7ae20ba173244851e82749dba31ba1320d83d021876f12350ecaa2fb03e47857fdc8013c87df6cae6e9250ec78548b498f35a92d305a28070475f36e4 SHA512 12bc17f39569f8b09c793d0e65b82926325c8d9046454e385ef7c82ab26f4e39e8f44f7491c80be71743abd78565bca50023b62365437fc8e43fc23d1b64840b
+DIST tg_owt-0_pre20241202.tar.gz 11722610 BLAKE2B effe7b833db593bdbf5d923b362cbc8839853e068d22ac1efd39ae8287eac0aeb71e74bf4476fa2a1a1b67c4e7370c6bc3b28d97e510c50b9621761b9b7be219 SHA512 10b7d0686fabc289694c659bcd138737b33375d0aad936e0cf8dcdebeebf30e7c0e1af7a9196c4275bcbb88b5867bcefa8179564980941895a6b7d9bfae822b2
diff --git a/media-libs/tg_owt/tg_owt-0_pre20241202.ebuild b/media-libs/tg_owt/tg_owt-0_pre20241202.ebuild
new file mode 100644
index 000000000000..5d3a7818e905
--- /dev/null
+++ b/media-libs/tg_owt/tg_owt-0_pre20241202.ebuild
@@ -0,0 +1,123 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="WebRTC build for Telegram"
+HOMEPAGE="https://github.com/desktop-app/tg_owt"
+
+TG_OWT_COMMIT="be39b8c8d0db1f377118f813f0c4bd331d341d5e"
+LIBYUV_COMMIT="04821d1e7d60845525e8db55c7bcd41ef5be9406"
+LIBSRTP_COMMIT="a566a9cfcd619e8327784aa7cff4a1276dc1e895"
+SRC_URI="https://github.com/desktop-app/tg_owt/archive/${TG_OWT_COMMIT}.tar.gz -> ${P}.tar.gz
+ https://gitlab.com/chromiumsrc/libyuv/-/archive/${LIBYUV_COMMIT}/libyuv-${LIBYUV_COMMIT}.tar.bz2
+ https://github.com/cisco/libsrtp/archive/${LIBSRTP_COMMIT}.tar.gz -> libsrtp-${LIBSRTP_COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${TG_OWT_COMMIT}"
+# Upstream libyuv: https://chromium.googlesource.com/libyuv/libyuv
+
+LICENSE="BSD"
+SLOT="0/${PV##*pre}"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv"
+IUSE="screencast +X"
+
+# This package's USE flags may change the ABI and require a rebuild of
+# dependent pacakges. As such, one should make sure to depend on
+# media-libs/tg_owt[x=,y=,z=] for any package that uses this.
+# Furthermore, the -DNDEBUG preprocessor flag should be defined by any
+# dependent package, failure to do so will change the ABI in the header files.
+
+# Bundled libs:
+# - libyuv (no stable versioning, www-client/chromium and media-libs/libvpx bundle it)
+# - libsrtp (project uses private APIs)
+# - pffft (no stable versioning, patched)
+RDEPEND="
+ >=dev-cpp/abseil-cpp-20240722.0:=
+ dev-libs/openssl:=
+ dev-libs/protobuf:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libvpx-1.10.0:=
+ media-libs/openh264:=
+ media-libs/opus
+ media-video/ffmpeg:=
+ dev-libs/crc32c
+ screencast? (
+ dev-libs/glib:2
+ >=media-video/pipewire-1.0.7:=
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ screencast? (
+ media-libs/libglvnd[X]
+ media-libs/mesa
+ x11-libs/libdrm
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ X? ( x11-base/xorg-proto )
+"
+
+src_unpack() {
+ default
+
+ mv -T "libyuv-${LIBYUV_COMMIT}" "${S}/src/third_party/libyuv" || die
+ mv -T "libsrtp-${LIBSRTP_COMMIT}" "${S}/src/third_party/libsrtp" || die
+}
+
+src_prepare() {
+ # The sources for these aren't available, avoid needing them
+ sed -e '/include(cmake\/libcrc32c.cmake)/d' \
+ -e '/include(cmake\/libabsl.cmake)/d' -i CMakeLists.txt || die
+
+ # "lol" said the scorpion, "lmao"
+ sed -i '/if (BUILD_SHARED_LIBS)/{n;n;s/WARNING/DEBUG/}' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Defined by -DCMAKE_BUILD_TYPE=Release, avoids crashes
+ # See https://bugs.gentoo.org/754012
+ # EAPI 8 still wipes this flag.
+ append-cppflags '-DNDEBUG'
+
+ local mycmakeargs=(
+ -DTG_OWT_USE_X11=$(usex X)
+ -DTG_OWT_USE_PIPEWIRE=$(usex screencast)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # Save about 15MB of useless headers
+ rm -r "${ED}/usr/include/tg_owt/rtc_base/third_party" || die
+ rm -r "${ED}/usr/include/tg_owt/common_audio/third_party" || die
+ rm -r "${ED}/usr/include/tg_owt/modules/third_party" || die
+ rm -r "${ED}/usr/include/tg_owt/third_party" || die
+
+ # Install a few headers anyway, as required by net-im/telegram-desktop...
+ local headers=(
+ third_party/libyuv/include
+ rtc_base/third_party/sigslot
+ rtc_base/third_party/base64
+ )
+ for dir in "${headers[@]}"; do
+ pushd "${S}/src/${dir}" > /dev/null || die
+ find -type f -name "*.h" -exec install -Dm644 '{}' "${ED}/usr/include/tg_owt/${dir}/{}" \; || die
+ popd > /dev/null || die
+ done
+}