summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-05-02 09:54:38 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-05-02 09:54:38 +0300
commit382a860b36e142b991954d1ea4a3cc3b920b3fb6 (patch)
treec2dee18e2148f896f50eb3b6b44ef8ae980a6ea1 /media-libs/rlottie
parentdev-java/swt: remove unused patches (diff)
downloadgentoo-382a860b36e142b991954d1ea4a3cc3b920b3fb6.tar.gz
gentoo-382a860b36e142b991954d1ea4a3cc3b920b3fb6.tar.bz2
gentoo-382a860b36e142b991954d1ea4a3cc3b920b3fb6.zip
media-libs/rlottie: add a snapshot build for 0.2 to fix gcc-11 compat
Closes: https://bugs.gentoo.org/787503 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/rlottie')
-rw-r--r--media-libs/rlottie/Manifest1
-rw-r--r--media-libs/rlottie/rlottie-0.2_p20210405.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/rlottie/Manifest b/media-libs/rlottie/Manifest
index f1c760fe4c76..1b5f363baf5b 100644
--- a/media-libs/rlottie/Manifest
+++ b/media-libs/rlottie/Manifest
@@ -1 +1,2 @@
DIST rlottie-0.2-1.tar.gz 3516947 BLAKE2B d5f6b643c910e0b831be223be4fcff3d42cde8239b01d413f2805eeccf2665abfbd209ee6877358c2434d3bc82ea7c5b3849f4dca1d0796436e47ffa6bcfed64 SHA512 1f645ae998ddbe83e4911addf28ec24ae3ff33f6439a9fb6c1e56986b46ac17dba155773ab02a59712e781febb31709a99075a3fbcda6136a0cb43dbd7c753de
+DIST rlottie-0.2_p20210405.tar.gz 4048368 BLAKE2B 46875135de630b8cae164bf9714abbfad389853aabf7e642c612b54ce50a3a0c105b57a314f0731aa69b4fd023e3638c122f0335a7ae886253a7bea0a5b3d51e SHA512 a0382bd9561cc47daafc0742db24c55efa25ec1c8e0d865ea49cf11d8f082b9f860dd673f4d0fbf95e02da708da164bc9a87c66b76cd58becf983c968e7aeb81
diff --git a/media-libs/rlottie/rlottie-0.2_p20210405.ebuild b/media-libs/rlottie/rlottie-0.2_p20210405.ebuild
new file mode 100644
index 000000000000..6e7414259752
--- /dev/null
+++ b/media-libs/rlottie/rlottie-0.2_p20210405.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="7c5b40cbb87422e5a74691d4d9907948c8c0d479"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL JSON MIT"
+SLOT="0/0.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+src_configure() {
+ local emesonargs=(
+ -D cache=true
+ -D module=true
+ -D thread=true
+
+ -D cmake=false
+ -D example=false
+
+ $(meson_use debug dumptree)
+ $(meson_use debug log)
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+ eninja test
+}