summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 06:02:22 +0000
committerSam James <sam@gentoo.org>2022-01-13 06:02:28 +0000
commit832c88a650fc794fd5105723656f8dee55488cf8 (patch)
tree79c6087dd0e7032f4f35c1b29b76e96ef9b66da2 /media-libs/phat
parentapp-crypt/adcli: add patch references (diff)
downloadgentoo-832c88a650fc794fd5105723656f8dee55488cf8.tar.gz
gentoo-832c88a650fc794fd5105723656f8dee55488cf8.tar.bz2
gentoo-832c88a650fc794fd5105723656f8dee55488cf8.zip
media-libs/phat: update EAPI 6 -> 8, build with lld
Was underlinking libm for e.g. exp(). Closes: https://bugs.gentoo.org/740162 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/phat')
-rw-r--r--media-libs/phat/files/phat-0.4.1-libm-underlinking.patch16
-rw-r--r--media-libs/phat/phat-0.4.1-r2.ebuild43
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/phat/files/phat-0.4.1-libm-underlinking.patch b/media-libs/phat/files/phat-0.4.1-libm-underlinking.patch
new file mode 100644
index 000000000000..f6e55b9fa18b
--- /dev/null
+++ b/media-libs/phat/files/phat-0.4.1-libm-underlinking.patch
@@ -0,0 +1,16 @@
+From: Sam James <sam@gentoo.org>
+Date: Thu, 13 Jan 2022 06:00:11 +0000
+Subject: [PATCH] Fix underlinking against libm
+
+Bug: https://bugs.gentoo.org/740162
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,6 +47,8 @@ GTK_DOC_CHECK(1.0)
+ # misc checks
+ PKG_CHECK_MODULES(MISC, libgnomecanvas-2.0 x11)
+
++AC_SEARCH_LIBS(exp, m)
++
+ # set compilation flags
+ CFLAGS="$CFLAGS $GTK_CFLAGS $MISC_CFLAGS -Wall"
+ LIBS="$LIBS $GTK_LIBS $MISC_LIBS"
diff --git a/media-libs/phat/phat-0.4.1-r2.ebuild b/media-libs/phat/phat-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..206b47e5d396
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="gnome-base/libgnomecanvas
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/gtk-doc
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+ "${FILESDIR}/${P}-libm-underlinking.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}