summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-07-14 15:30:52 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-07-14 15:31:18 -0400
commit58b7ccd4efe36912ad3cf661ba872d94f2bbeed1 (patch)
treefc0b37dfd8824a642a6fdc284f9264a0d88b6786 /media-libs/openh264/openh264-1.7.0.ebuild
parentsci-geosciences/opencpn: bump version, fix bug #623838 (diff)
downloadgentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.tar.gz
gentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.tar.bz2
gentoo-58b7ccd4efe36912ad3cf661ba872d94f2bbeed1.zip
media-libs/openh264: version bump to 1.7.0
Upstream release notes courtesy the gentoo bug below: - Changed SPS/PPS strategy option name,See enum ENCODER_OPTION - Changed NAL size length parameter from static array to pointer to support more NALs.See struct SParserBsInfo - Changed semaphores to condition variables on apple platform - Changed version update mechanism as Major.Minor.patch,like 1.7.0 - Supported to force IDR independently for each layer in simulcast AVC case.See API ForceIntraFrame() - Supported LTR request independently for each layer in simulcast AVC case. See struct SLTRRecoverRequest and SLTRMarkingFeedback - Supported to set sample aspect ratio in VUI on encoder side. See struct SSpatialLayerConfig - Supported to set profile and level, changed the default level as 4.1 if the user doesn’t set it. See enum ELevelIdc - Supported to get profile and level info on decoder side.See enum DECODER_OPTION - Supported for enable/disable AVX2 build option. Build option: HAVE_AVX2 - Supported to set decoder statistics log interval, Add DECODER_OPTION_STATISTICS_LOG_INTERVAL.See DECODER_OPTION. - Supported for AU delimiter NAL on decoder side. AU delimiter refers to section 7.3.2.4 - Supported for x86 PIC assembly and build option. Build option: ENABLEPIC. git issues:#2263 #2534 - Supported for Cygwin x86_64 build - Supported to get sample aspect ratio by GetOption on decoder. Add option: DECODER_OPTION_GET_SAR_INFO - Set constraint_set4_flag constraint_set5_flag to align to CHP definition in latest H264 standard - Improved VUI support on decoder side - Improved decoder statistics info output - Refined the return value when failed in memory allocation - Added SSSE3 motion compensation routines - Added AVX2 motion compensation routines - Optimization on some of SSE2/MMX functions - Refactor rate control for RC_BUFFERBASED_MODE and RC_QUALITY_MODE mode - Added more unit tests for random resolution input,slice mode switch, profile/level setting - Refined logs - Bug fixes for 4:0:0 format support on decoder - Bug fixes for complexity calculation for screen content mode - Bug fixes for loadbalancing turn on, git issue:#2618 - Bug fixes for parser subsps, scalling list, parser longer bitstream Bug: http://bugs.gentoo.org/622170 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'media-libs/openh264/openh264-1.7.0.ebuild')
-rw-r--r--media-libs/openh264/openh264-1.7.0.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/media-libs/openh264/openh264-1.7.0.ebuild b/media-libs/openh264/openh264-1.7.0.ebuild
new file mode 100644
index 000000000000..0296f9e0e9e8
--- /dev/null
+++ b/media-libs/openh264/openh264-1.7.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit nsplugins multilib-minimal
+
+MOZVER=39
+DESCRIPTION="Cisco OpenH264 library and Gecko Media Plugin for Mozilla packages"
+HOMEPAGE="http://www.openh264.org/"
+SRC_URI="https://github.com/cisco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mozilla/gmp-api/archive/Firefox${MOZVER}.tar.gz -> gmp-api-Firefox${MOZVER}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+plugin utils"
+
+RESTRICT="bindist"
+
+RDEPEND="!<www-client/firefox-${MOZVER}"
+DEPEND="
+ abi_x86_32? ( dev-lang/nasm )
+ abi_x86_64? ( dev-lang/nasm )"
+
+DOCS=( LICENSE CONTRIBUTORS README.md )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.0-pkgconfig-pathfix.patch
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ln -s "${WORKDIR}"/gmp-api-Firefox${MOZVER} gmp-api || die
+}
+
+emakecmd() {
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ emake V=Yes CFLAGS_M32="" CFLAGS_M64="" CFLAGS_OPT="" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR_NAME="$(get_libdir)" \
+ SHAREDLIB_DIR="${EPREFIX}/usr/$(get_libdir)" \
+ INCLUDES_DIR="${EPREFIX}/usr/include/${PN}" \
+ $@
+}
+
+multilib_src_compile() {
+ local mybits="ENABLE64BIT=No"
+ case "${ABI}" in
+ s390x|alpha|*64) mybits="ENABLE64BIT=Yes";;
+ esac
+
+ emakecmd ${mybits} ${tgt}
+ use plugin && emakecmd ${mybits} plugin
+}
+
+multilib_src_install() {
+ emakecmd DESTDIR="${D}" install-shared
+
+ use utils && dobin h264{enc,dec}
+
+ if use plugin; then
+ local plugpath="usr/$(get_libdir)/${PLUGINS_DIR}/gmp-gmp${PN}/system-installed"
+ insinto "/${plugpath}"
+ doins libgmpopenh264.so* gmpopenh264.info
+ echo "MOZ_GMP_PATH=\"${EROOT}${plugpath}\"" >"${T}"/98-moz-gmp-${PN}
+ doenvd "${T}"/98-moz-gmp-${PN}
+
+ cat <<PREFEOF >"${T}"/${P}.js
+pref("media.gmp-gmp${PN}.autoupdate", false);
+pref("media.gmp-gmp${PN}.version", "system-installed");
+PREFEOF
+
+ insinto /usr/$(get_libdir)/firefox/defaults/pref
+ doins "${T}"/${P}.js
+
+ insinto /usr/$(get_libdir)/seamonkey/defaults/pref
+ doins "${T}"/${P}.js
+ fi
+}
+
+pkg_postinst() {
+ if use plugin; then
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please restart your login session, in order for the session's environment"
+ elog "to include the new MOZ_GMP_PATH variable."
+ elog ""
+ fi
+ elog "This package attempts to override the Mozilla GMPInstaller auto-update process,"
+ elog "however even if it is not successful in doing so the profile-installed plugin"
+ elog "will not be used unless this package is removed. This package will take precedence"
+ elog "over any gmp-gmpopenh264 that may be installed in a user's profile."
+ elog ""
+ fi
+}