summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-06 11:56:31 +0100
committerSam James <sam@gentoo.org>2024-08-06 11:56:31 +0100
commitd1f2d392deaed8e6b7af6aa183ac182b2ce3a9a3 (patch)
tree27345eb3c8c81cde0fb54a0b5ef18610b29f3786 /media-libs/openal
parentdev-util/ccls: fix build w/ gcc-15 (diff)
downloadgentoo-d1f2d392deaed8e6b7af6aa183ac182b2ce3a9a3.tar.gz
gentoo-d1f2d392deaed8e6b7af6aa183ac182b2ce3a9a3.tar.bz2
gentoo-d1f2d392deaed8e6b7af6aa183ac182b2ce3a9a3.zip
media-libs/openal: fix build w/ gcc-15
It's fixed more exhaustively upstream in git already. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/files/openal-1.23.1-gcc15-cstdint.patch32
-rw-r--r--media-libs/openal/openal-1.23.1-r1.ebuild6
2 files changed, 37 insertions, 1 deletions
diff --git a/media-libs/openal/files/openal-1.23.1-gcc15-cstdint.patch b/media-libs/openal/files/openal-1.23.1-gcc15-cstdint.patch
new file mode 100644
index 000000000000..ce4ceb455b2f
--- /dev/null
+++ b/media-libs/openal/files/openal-1.23.1-gcc15-cstdint.patch
@@ -0,0 +1,32 @@
+Fixed exhaustively upstream in https://github.com/kcat/openal-soft/commit/64f8e8347f7ed3f98917fae7587f4d72b54c28ef
+but doesn't apply cleanly, so do a minimal fix here.
+--- a/alc/alu.h
++++ b/alc/alu.h
+@@ -2,6 +2,7 @@
+ #define ALU_H
+
+ #include <bitset>
++#include <cstdint>
+
+ #include "aloptional.h"
+
+--- a/core/mixer/defs.h
++++ b/core/mixer/defs.h
+@@ -2,6 +2,7 @@
+ #define CORE_MIXER_DEFS_H
+
+ #include <array>
++#include <cstdint>
+ #include <stdlib.h>
+
+ #include "alspan.h"
+--- a/core/uhjfilter.h
++++ b/core/uhjfilter.h
+@@ -2,6 +2,7 @@
+ #define CORE_UHJFILTER_H
+
+ #include <array>
++#include <cstdint>
+
+ #include "almalloc.h"
+ #include "alspan.h"
diff --git a/media-libs/openal/openal-1.23.1-r1.ebuild b/media-libs/openal/openal-1.23.1-r1.ebuild
index 577f84a4b295..2c46a9584900 100644
--- a/media-libs/openal/openal-1.23.1-r1.ebuild
+++ b/media-libs/openal/openal-1.23.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -51,6 +51,10 @@ DEPEND="
DOCS=( alsoftrc.sample docs/env-vars.txt docs/hrtf.txt ChangeLog README.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.23.1-gcc15-cstdint.patch
+)
+
multilib_src_configure() {
local mycmakeargs=(
# See bug #809314 for getting both options for backends