summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2020-11-16 12:16:24 +0800
committerMatt Turner <mattst88@gentoo.org>2020-11-16 23:45:24 -0500
commit88d0192a2531f59099898c3fc160be39f7ef6724 (patch)
tree397831af8938f1321c4924df4c160eeafdc8cc0c /media-libs/mesa
parentx11-libs/libdrm: Version bump to 2.4.103 (diff)
downloadgentoo-88d0192a2531f59099898c3fc160be39f7ef6724.tar.gz
gentoo-88d0192a2531f59099898c3fc160be39f7ef6724.tar.bz2
gentoo-88d0192a2531f59099898c3fc160be39f7ef6724.zip
media-libs/mesa: add video_cards_v3d to vulkan support list
Raspberry Pi's V3DV Vulkan Driver has now landed in mainline Mesa and this PR allows V3DV vulkan driver to be built in live version. Closes: https://github.com/gentoo/gentoo/pull/18274 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index b128d3746f5c..b2b79088f3cc 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -259,8 +259,9 @@ pkg_pretend() {
if use vulkan; then
if ! use video_cards_i965 &&
! use video_cards_iris &&
- ! use video_cards_radeonsi; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, or radeonsi"
+ ! use video_cards_radeonsi &&
+ ! use video_cards_v3d; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, radeonsi, or v3d"
fi
fi
@@ -473,6 +474,7 @@ multilib_src_configure() {
vulkan_enable video_cards_i965 intel
vulkan_enable video_cards_iris intel
vulkan_enable video_cards_radeonsi amd
+ vulkan_enable video_cards_v3d broadcom
fi
if use gallium; then