summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-26 14:41:53 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-26 16:31:25 -0400
commit26d39ee7495db76e0c377ded8753dbf5a2c7305c (patch)
tree91605620a13bb11d1da9c2651f65c4ad6d4f5ff6 /media-libs/libptp2/libptp2-1.1.10.ebuild
parentapp-benchmarks/acovea: drop EAPI=2 (diff)
downloadgentoo-26d39ee7495db76e0c377ded8753dbf5a2c7305c.tar.gz
gentoo-26d39ee7495db76e0c377ded8753dbf5a2c7305c.tar.bz2
gentoo-26d39ee7495db76e0c377ded8753dbf5a2c7305c.zip
media-libs/libptp2: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/libptp2/libptp2-1.1.10.ebuild')
-rw-r--r--media-libs/libptp2/libptp2-1.1.10.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/media-libs/libptp2/libptp2-1.1.10.ebuild b/media-libs/libptp2/libptp2-1.1.10.ebuild
index e41d7e0a657b..ceffdf3f139f 100644
--- a/media-libs/libptp2/libptp2-1.1.10.ebuild
+++ b/media-libs/libptp2/libptp2-1.1.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
+inherit autotools
DESCRIPTION="Library and client to communicate with cameras via PTP"
HOMEPAGE="https://sourceforge.net/projects/libptp/"
@@ -16,11 +16,13 @@ IUSE=""
RDEPEND="virtual/libusb:0"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-configure.patch
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-configure.patch"
+)
+src_prepare() {
+ default
AT_M4DIR="m4" eautoreconf
}
@@ -30,4 +32,5 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install || die
+ default
}