summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/giblib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/giblib')
-rw-r--r--media-libs/giblib/Manifest1
-rw-r--r--media-libs/giblib/giblib-1.2.4-r1.ebuild32
-rw-r--r--media-libs/giblib/giblib-1.2.4.ebuild33
-rw-r--r--media-libs/giblib/metadata.xml16
4 files changed, 82 insertions, 0 deletions
diff --git a/media-libs/giblib/Manifest b/media-libs/giblib/Manifest
new file mode 100644
index 000000000000..43a41e9bb071
--- /dev/null
+++ b/media-libs/giblib/Manifest
@@ -0,0 +1 @@
+DIST giblib-1.2.4.tar.gz 287653 SHA256 176611c4d88d742ea4013991ad54c2f9d2feefbc97a28434c0f48922ebaa8bac SHA512 4866df223e6d219a5c9a327874bcd67260c83fba8f99862222df41ef86fb31efa0172a777bf46c853ca380dc2a64bbd41bf4fd658fcb84a924cab4e0f525dcfd WHIRLPOOL b2668cb8a27dc16f279e9b0215eb4729548033a74eeec37cfc13788c4a572fd2eadf451704b80da2903d5a41f3e8833e4fdbe526efe36d35a8db07b747264f77
diff --git a/media-libs/giblib/giblib-1.2.4-r1.ebuild b/media-libs/giblib/giblib-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..52edced574fa
--- /dev/null
+++ b/media-libs/giblib/giblib-1.2.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils libtool
+
+DESCRIPTION="a graphics library built on top of imlib2"
+HOMEPAGE="http://freecode.com/projects/giblib http://www.linuxbrit.co.uk/giblib/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/imlib2-1.0.3[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ >=media-libs/freetype-2.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i 's:@LDFLAGS@::' giblib-config.in giblib.pc.in || die #430724
+ sed -i "/^docsdir/s:=.*:= @datadir@/doc/${PF}:" Makefile.in || die
+ epunt_cxx
+ elibtoolize # otherwise it doesnt install the .so -> .so.x symlink on fbsd
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
diff --git a/media-libs/giblib/giblib-1.2.4.ebuild b/media-libs/giblib/giblib-1.2.4.ebuild
new file mode 100644
index 000000000000..5e275f7613c9
--- /dev/null
+++ b/media-libs/giblib/giblib-1.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Giblib, graphics library"
+HOMEPAGE="http://www.linuxbrit.co.uk/giblib/"
+SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
+
+LICENSE="feh"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/imlib2-1.0.3[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ >=media-libs/freetype-2.0"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epunt_cxx
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm -r "${D}"/usr/doc
+ dodoc README AUTHORS ChangeLog TODO
+}
diff --git a/media-libs/giblib/metadata.xml b/media-libs/giblib/metadata.xml
new file mode 100644
index 000000000000..2a8e42b4aa1d
--- /dev/null
+++ b/media-libs/giblib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <longdescription>
+giblib is a utility library used by many of the applications I write. It
+incorporates doubly linked lists, some string functions, and a wrapper
+for imlib2. The wrapper does two things. It gives you access to
+fontstyles, which can be loaded from files, saved to files or defined
+dynamically through the API. It also, and more importantly, wraps
+imlib2's context API changing.
+</longdescription>
+ <upstream>
+ <remote-id type="freecode">giblib</remote-id>
+ </upstream>
+</pkgmetadata>