summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-12 00:42:00 -0400
committerSam James <sam@gentoo.org>2024-03-12 05:15:40 +0000
commit8994f0c196a97bec1bc50259d462565efb937e4f (patch)
tree14b092955d0763c8b841cacd106605cf598f900c /media-libs/devil
parentnet-print/mtink: fix LTO and Modern C bugs (diff)
downloadgentoo-8994f0c196a97bec1bc50259d462565efb937e4f.tar.gz
gentoo-8994f0c196a97bec1bc50259d462565efb937e4f.tar.bz2
gentoo-8994f0c196a97bec1bc50259d462565efb937e4f.zip
media-libs/devil: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/859835 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/devil')
-rw-r--r--media-libs/devil/devil-1.7.8-r6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-libs/devil/devil-1.7.8-r6.ebuild b/media-libs/devil/devil-1.7.8-r6.ebuild
index ea29d4edf855..fafa062a9f18 100644
--- a/media-libs/devil/devil-1.7.8-r6.ebuild
+++ b/media-libs/devil/devil-1.7.8-r6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
MY_P=DevIL-${PV}
@@ -58,6 +58,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/859835
+ # https://github.com/DentonW/DevIL/issues/110
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable static-libs static) \
--disable-lcms \