summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/alsa-oss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/alsa-oss')
-rw-r--r--media-libs/alsa-oss/Manifest2
-rw-r--r--media-libs/alsa-oss/alsa-oss-1.0.25-r1.ebuild43
-rw-r--r--media-libs/alsa-oss/alsa-oss-1.0.25.ebuild38
-rw-r--r--media-libs/alsa-oss/alsa-oss-1.0.28.ebuild42
-rw-r--r--media-libs/alsa-oss/files/alsa-oss-1.0.12-hardened.patch13
-rw-r--r--media-libs/alsa-oss/metadata.xml8
6 files changed, 146 insertions, 0 deletions
diff --git a/media-libs/alsa-oss/Manifest b/media-libs/alsa-oss/Manifest
new file mode 100644
index 000000000000..7c481712a7f2
--- /dev/null
+++ b/media-libs/alsa-oss/Manifest
@@ -0,0 +1,2 @@
+DIST alsa-oss-1.0.25.tar.bz2 253409 SHA256 ed823b8e42599951d896c1709615d4cf7cb1cb3a7c55c75ccee82e24ccaf28e3 SHA512 5380e5acf588dd56384f53afedc7704bfc5e3a7b886853061c53236f86312a8f0ca9b9adf6e69019569a3eb6fd3e89acfb715bb16101f50dcf961e84269c3cd2 WHIRLPOOL 27f19ae9b43d6941fdafb8e51ef0e7cd2667a6a6a8babf58303a0468bad02a33fd2562e91e5c92941083f7a0b2b4e17d4a001c41370bf6cddd29182b17ee4ca0
+DIST alsa-oss-1.0.28.tar.bz2 291500 SHA256 3ae62caa88a0bc7b30ed836dcb794dc6ef4d3650439e2260db54cace7d5c6ad5 SHA512 7069b7d4d4c0b840608dcca99a660aae1f81f6ef45dcf48fc66553b05de260d033105aa685c8ca05fd4d157d12d83860746a05afdab4f310919c34fa235ab03e WHIRLPOOL 02c7dfadbd30baaf86094a0ffff996eec5bf67aed7f49dc915d29b9a0318345415a1bd9c776967e1dc9da3c9dd180169f61950fd1454fa28837e35631cb83efe
diff --git a/media-libs/alsa-oss/alsa-oss-1.0.25-r1.ebuild b/media-libs/alsa-oss/alsa-oss-1.0.25-r1.ebuild
new file mode 100644
index 000000000000..3294547eb155
--- /dev/null
+++ b/media-libs/alsa-oss/alsa-oss-1.0.25-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib multilib-minimal
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture OSS compatibility layer"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/oss-lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.12-hardened.patch" )
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+ sed -i -e 's:\${exec_prefix}/\\$LIB/::' "${D}/usr/bin/aoss" || die
+}
diff --git a/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild b/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild
new file mode 100644
index 000000000000..bd67706bc868
--- /dev/null
+++ b/media-libs/alsa-oss/alsa-oss-1.0.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools base multilib
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture OSS compatibility layer"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/oss-lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.12-hardened.patch" )
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ sed -i -e 's:\${exec_prefix}/\\$LIB/::' "${D}/usr/bin/aoss"
+ find "${D}" -name "*.la" -delete
+}
diff --git a/media-libs/alsa-oss/alsa-oss-1.0.28.ebuild b/media-libs/alsa-oss/alsa-oss-1.0.28.ebuild
new file mode 100644
index 000000000000..0b95c44a4509
--- /dev/null
+++ b/media-libs/alsa-oss/alsa-oss-1.0.28.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib multilib-minimal
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture OSS compatibility layer"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/oss-lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.12-hardened.patch" )
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable static-libs static)
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+ sed -i -e 's:\${exec_prefix}/\\$LIB/::' "${D}/usr/bin/aoss" || die
+}
diff --git a/media-libs/alsa-oss/files/alsa-oss-1.0.12-hardened.patch b/media-libs/alsa-oss/files/alsa-oss-1.0.12-hardened.patch
new file mode 100644
index 000000000000..847a7da932f8
--- /dev/null
+++ b/media-libs/alsa-oss/files/alsa-oss-1.0.12-hardened.patch
@@ -0,0 +1,13 @@
+Index: alsa-oss-1.0.12/test/Makefile.am
+===================================================================
+--- alsa-oss-1.0.12.orig/test/Makefile.am
++++ alsa-oss-1.0.12/test/Makefile.am
+@@ -7,7 +7,7 @@ lmixer_SOURCES=lmixer.cc
+ noinst_HEADERS = mixctl.h
+
+ INCLUDES=-I$(top_srcdir)/oss-redir
+-AM_CFLAGS=-static -Wall -pipe -g
++AM_CFLAGS=-Wall -pipe -g
+
+ EXTRA_DIST=
+
diff --git a/media-libs/alsa-oss/metadata.xml b/media-libs/alsa-oss/metadata.xml
new file mode 100644
index 000000000000..8987e55f2c06
--- /dev/null
+++ b/media-libs/alsa-oss/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>alsa</herd>
+<maintainer>
+<email>alsa-bugs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>