summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-04 15:56:20 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-06 11:21:17 +0200
commitf73b26991974c225a6504673ecf25d09dff9c90b (patch)
treeabdc2633bbc1b1cbd9ee5403d2b2555a34db3942 /media-gfx
parentmedia-gfx/eog: Fix VariableOrderWrong warning (diff)
downloadgentoo-f73b26991974c225a6504673ecf25d09dff9c90b.tar.gz
gentoo-f73b26991974c225a6504673ecf25d09dff9c90b.tar.bz2
gentoo-f73b26991974c225a6504673ecf25d09dff9c90b.zip
media-gfx/eog-plugins: Bump to 44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37957 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-44.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index acf2bd547745..4687c97c1c9e 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-44.0.tar.xz 134544 BLAKE2B db384d949f2a63cb0fcdf1bdfb8ed4c5c97af88d21079af5de7560b3c3bab231a6361ae459727a9b9f31b49e63f7cd227f465a1a7b8e2bc55e8d7a08f0335ed9 SHA512 2955830aa60a3518869ec1af7a9f0c455277b0a571cb14a5e5926b52b80ed0443e91f28e270feffcf26066e1e9b6080c9a457b55175051c20838c8b80e2da195
+DIST eog-plugins-44.1.tar.xz 136392 BLAKE2B b46a8f283798f83b43a82c53c29b98182e7069cf4f5771ba1b5e888c285ddc10dd98fd81eeb8e4350ddf4b8fb0a0c4158673bcf920810e72dc8895ee61835014 SHA512 63fee6b9f1809a7c435ff27649805746d98b3e25c5a8fe2dd0146f7748d33b140c7f5b64598ff0bea427a55bb39d990c5ca19e975cf6bb8ec234f46937b50f29
diff --git a/media-gfx/eog-plugins/eog-plugins-44.1.ebuild b/media-gfx/eog-plugins/eog-plugins-44.1.ebuild
new file mode 100644
index 000000000000..ac59330849d4
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-44.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:0
+ >=media-gfx/eog-41.0:1
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:0[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ -Dplugin_postasa=false
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}