summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-17 08:04:54 +0100
committerSam James <sam@gentoo.org>2024-10-17 08:06:58 +0100
commit0e21aff244a4247a58729df0d641538b1b767296 (patch)
treef271e22a3b587d4e27cd50e8d2542ab0de9853b7 /media-gfx
parentdev-ruby/rspec-expectations: Stabilize 3.13.3 ppc64, #941665 (diff)
downloadgentoo-0e21aff244a4247a58729df0d641538b1b767296.tar.gz
gentoo-0e21aff244a4247a58729df0d641538b1b767296.tar.bz2
gentoo-0e21aff244a4247a58729df0d641538b1b767296.zip
media-gfx/inkscape: fix build w/ gcc-15
Closes: https://bugs.gentoo.org/941674 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/inkscape/files/inkscape-1.4-gcc15.patch21
-rw-r--r--media-gfx/inkscape/inkscape-1.4.ebuild4
2 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/inkscape/files/inkscape-1.4-gcc15.patch b/media-gfx/inkscape/files/inkscape-1.4-gcc15.patch
new file mode 100644
index 000000000000..e27db0be34ef
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-1.4-gcc15.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/941674
+https://gitlab.com/inkscape/inkscape/-/commit/eb6dadcf1a5c660167ba43f3606c8e7cc6529787
+
+From eb6dadcf1a5c660167ba43f3606c8e7cc6529787 Mon Sep 17 00:00:00 2001
+From: Liam <byteslice@airmail.cc>
+Date: Sat, 12 Oct 2024 05:22:29 -0400
+Subject: [PATCH] gobjectptr: fix member name
+
+--- a/src/util/gobjectptr.h
++++ b/src/util/gobjectptr.h
+@@ -20,7 +20,7 @@ public:
+ GObjectPtr() = default;
+ explicit GObjectPtr(T *p, bool add_ref = false) : _p(p) { if (add_ref) _ref(); }
+ GObjectPtr(GObjectPtr const &other) : _p(other._p) { _ref(); }
+- GObjectPtr &operator=(GObjectPtr const &other) { if (&other != this) { _unref(); _p = other.p; _ref(); } return *this; }
++ GObjectPtr &operator=(GObjectPtr const &other) { if (&other != this) { _unref(); _p = other._p; _ref(); } return *this; }
+ GObjectPtr(GObjectPtr &&other) noexcept : _p(other._p) { other._p = nullptr; }
+ GObjectPtr &operator=(GObjectPtr &&other) { if (&other != this) { _unref(); _p = other._p; other._p = nullptr; } return *this; }
+ ~GObjectPtr() { _unref(); }
+--
+GitLab
diff --git a/media-gfx/inkscape/inkscape-1.4.ebuild b/media-gfx/inkscape/inkscape-1.4.ebuild
index eab33b71e0fe..ddbdde41002c 100644
--- a/media-gfx/inkscape/inkscape-1.4.ebuild
+++ b/media-gfx/inkscape/inkscape-1.4.ebuild
@@ -108,6 +108,10 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-cpp/gtest )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-gcc15.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}