summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-10-20 13:30:29 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-10-20 13:31:00 +0200
commit0b147716b72e43f34176510ecdf55e83ed5ae817 (patch)
tree348923958d6ffa5771e3ac89936f0bddaad74048 /media-gfx
parentapp-backup/bacula: Drop reliance on 'which' command (diff)
downloadgentoo-0b147716b72e43f34176510ecdf55e83ed5ae817.tar.gz
gentoo-0b147716b72e43f34176510ecdf55e83ed5ae817.tar.bz2
gentoo-0b147716b72e43f34176510ecdf55e83ed5ae817.zip
media-gfx/wings: add 2.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/wings/Manifest1
-rw-r--r--media-gfx/wings/files/wings-2.3-nogit.patch13
-rw-r--r--media-gfx/wings/wings-2.3.ebuild62
3 files changed, 76 insertions, 0 deletions
diff --git a/media-gfx/wings/Manifest b/media-gfx/wings/Manifest
index 3dca7377222e..a06c09c103b1 100644
--- a/media-gfx/wings/Manifest
+++ b/media-gfx/wings/Manifest
@@ -1 +1,2 @@
DIST wings-2.2.6.1.tar.bz2 3266532 BLAKE2B a3ec86925632df7d231d620a47841781f8b2e66a50d13857c57fa6389890e7a03fed8bf5e0d09b03de00d6360ee0e4129a4178aec34270367879890f9430c208 SHA512 dba4b189c80180533b7a6c10be5c236a4a9fdacaa7dc491a0d1892149f7a75e636778acc11e38ef82a06718ae705e640da2e1618ec655828d2056e6b3864aba4
+DIST wings-2.3.tar.bz2 3561319 BLAKE2B 0f3dce900dcae74516b57555f188aa578a5ea138d0e55e2b15ba946581652e470f5f596bd7e7661394674d437c8cbbe395bbf2e769af2a77d6940fddab1c86df SHA512 b5b054d974af2443cbe7d46a32cb8dfb7641054fa68aea9245e3d3100b21d223f443171572c3f371f25d937dca8cdb11870c61ba21e28632afef7886b4b2487b
diff --git a/media-gfx/wings/files/wings-2.3-nogit.patch b/media-gfx/wings/files/wings-2.3-nogit.patch
new file mode 100644
index 000000000000..734fbbeb717d
--- /dev/null
+++ b/media-gfx/wings/files/wings-2.3-nogit.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2024-10-20 12:12:36.987424596 +0200
++++ b/Makefile 2024-10-20 12:13:55.487467140 +0200
+@@ -14,10 +14,8 @@
+ # Check if OpenCL package is as external dependency
+ CL_PATH = $(shell $(ERL) -noshell -eval 'erlang:display(code:which(cl))' -s erlang halt)
+ ifneq (,$(findstring non_existing, $(CL_PATH)))
+-DEPS=cl
+ endif
+
+-DEPS += libigl eigen
+ SUBDIRS=c_src intl_tools src e3d plugins_src icons
+
+ #
diff --git a/media-gfx/wings/wings-2.3.ebuild b/media-gfx/wings/wings-2.3.ebuild
new file mode 100644
index 000000000000..a822318d4c2a
--- /dev/null
+++ b/media-gfx/wings/wings-2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="Wings 3D is an advanced subdivision modeler"
+HOMEPAGE="http://www.wings3d.com/"
+SRC_URI="https://downloads.sourceforge.net/wings/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >dev-lang/erlang-21[wxwidgets]
+ dev-libs/cl
+ media-libs/glu
+ media-libs/libsdl[opengl]
+ virtual/opengl
+ dev-cpp/eigen
+ sci-libs/libigl
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${P}-nogit.patch )
+
+src_prepare() {
+ sed -i -e 's# -Werror##g;s# -O3##g' $(find -name Makefile) || die
+ sed -i \
+ -e "s|IGL_INCLUDE = .*$|IGL_INCLUDE=-I/usr/include/eigen3|" \
+ c_src/Makefile \
+ || die
+ default
+}
+
+src_compile() {
+ export ERL_PATH="/usr/$(get_libdir)/erlang/lib/"
+ tc-export CC
+ # Work around parallel make issues
+ # Set ER_LIBS to the top source directory
+ emake vsn.mk
+ for subdir in intl_tools e3d src plugins_src icons; do
+ emake -C ${subdir} opt ERL_LIBS="${S}"
+ done
+ default
+}
+
+src_install() {
+ WINGS_PATH=${ERL_PATH}/${P}
+ dodir ${WINGS_PATH}
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${WINGS_PATH}
+ doins -r e3d ebin icons plugins priv psd shaders src textures tools
+
+ newbin "${FILESDIR}"/wings.sh-r1 wings
+ dodoc AUTHORS
+}