summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-11 05:00:40 +0100
committerSam James <sam@gentoo.org>2023-04-11 05:06:58 +0100
commitc56c7d636f0a6a3d1db6949db83d078a01bec0e7 (patch)
tree6c8e89cafdb3cad74f89dd8bbd87d9821230e065 /media-gfx/scrot
parentnet-analyzer/scapy: add TODO re changes for next release (diff)
downloadgentoo-c56c7d636f0a6a3d1db6949db83d078a01bec0e7.tar.gz
gentoo-c56c7d636f0a6a3d1db6949db83d078a01bec0e7.tar.bz2
gentoo-c56c7d636f0a6a3d1db6949db83d078a01bec0e7.zip
media-gfx/scrot: add 1.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/scrot')
-rw-r--r--media-gfx/scrot/Manifest1
-rw-r--r--media-gfx/scrot/scrot-1.9.ebuild61
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild2
3 files changed, 63 insertions, 1 deletions
diff --git a/media-gfx/scrot/Manifest b/media-gfx/scrot/Manifest
index e0bcc43cf203..dcf2acb40c79 100644
--- a/media-gfx/scrot/Manifest
+++ b/media-gfx/scrot/Manifest
@@ -1 +1,2 @@
DIST scrot-1.8.1.tar.gz 178856 BLAKE2B c7c6a5169112d38f1b919c651f5b5d99abd3adcf7bdbffd971c358b3c691297ff3bca6e7d82a0fa4e63323ee50651b477f7daab2ea383eb161446b41cd75516d SHA512 a93b3ce0fc690687b50d9b06d93b30528c26f3ee0b63d16895280d0df092fea022105a6d1aa60cf58c125a5b63eda841e089123d589354901b3ed6e063b76d86
+DIST scrot-1.9.tar.bz2 158710 BLAKE2B d823c0875a260ee9741e1c9038fe743e69d0afa83220448857d109dd3ebad9977f07871b25c6a4a979efdf2abd246a2facec91c5b0af01c47307dc6266c801d3 SHA512 ace3bcb26ecebc5bb139a6e011a562287be8f676f21211b540dd937ab2d4487047d3565d0aec84e099bd2c5c9b037d9044924b031f930dc45a3040df399a3312
diff --git a/media-gfx/scrot/scrot-1.9.ebuild b/media-gfx/scrot/scrot-1.9.ebuild
new file mode 100644
index 000000000000..4cde5c2086b1
--- /dev/null
+++ b/media-gfx/scrot/scrot-1.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Screen capture utility using imlib2 library"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/scrot"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="feh LGPL-2+"
+SLOT="0"
+
+# imlib2[X] needed for imlib_create_image_from_drawable, bug #835582
+RDEPEND="
+ dev-libs/libbsd
+ media-libs/imlib2[X,filters(+),text(+)]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXinerama
+ || (
+ media-libs/imlib2[gif]
+ media-libs/imlib2[jpeg]
+ media-libs/imlib2[png]
+ media-libs/imlib2[tiff]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog README.md
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_install() {
+ default
+
+ newbashcomp "${FILESDIR}"/${PN}-1.7.bash-completion ${PN}
+}
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index f8c2de9e5910..4cde5c2086b1 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/resurrecting-open-source-projects/${PN}"
inherit autotools git-r3
else
- SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi