summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-09 00:53:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-14 23:55:27 +0100
commit6eda645073f1a7c67b11175d805cf1dfb31f97b0 (patch)
tree5d16e707e584cda57cc3a0342682f89954d7f7c3 /media-gfx/photoqt
parentnet-libs/meanwhile: add 1.1.1, EAPI-8, new repository, HOMEPAGE (diff)
downloadgentoo-6eda645073f1a7c67b11175d805cf1dfb31f97b0.tar.gz
gentoo-6eda645073f1a7c67b11175d805cf1dfb31f97b0.tar.bz2
gentoo-6eda645073f1a7c67b11175d805cf1dfb31f97b0.zip
media-gfx/photoqt: add 3.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/photoqt')
-rw-r--r--media-gfx/photoqt/Manifest1
-rw-r--r--media-gfx/photoqt/photoqt-3.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-gfx/photoqt/Manifest b/media-gfx/photoqt/Manifest
index 4e6d861d95f5..dafca25005d1 100644
--- a/media-gfx/photoqt/Manifest
+++ b/media-gfx/photoqt/Manifest
@@ -1 +1,2 @@
DIST photoqt-3.2.tar.gz 965895 BLAKE2B ae1e159401b24a1bede344e4d398dbd6c2ae13fd467a4eac9ef15ea2d15933dc1756325a5a4f305a5f447bfd1a9e2d636e0b9367d0201ca356393c033c4f2f0f SHA512 ab7030d0ed6edf79373b1a99b1b8469cd567f04e5c233a87496084424603d8c241f7b473c22d323f4df8480d3f74918a987d2d590ec5026f1b7ca2c92b5c6bba
+DIST photoqt-3.3.tar.gz 1407575 BLAKE2B 8106519dbce79e523ca350a664ef38f20016538407baaef7757183fcd3e5d0351610265cffd53a6d188da8aa3167456b4ed5db0527d673c276ba2a8331bce802 SHA512 d21537b5f56e016b49be6dfd91c47c4acf26d739921a44242a8f53dd3e5bea00c807bf71b4224f689e25b23f5c0126aa5258ffe0ad1ff50e4c895aa7ba523fd5
diff --git a/media-gfx/photoqt/photoqt-3.3.ebuild b/media-gfx/photoqt/photoqt-3.3.ebuild
new file mode 100644
index 000000000000..e6de5535bbdb
--- /dev/null
+++ b/media-gfx/photoqt/photoqt-3.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_KDEINSTALLDIRS=false
+inherit ecm optfeature
+
+DESCRIPTION="Simple but powerful Qt-based image viewer"
+HOMEPAGE="https://photoqt.org/"
+SRC_URI="https://photoqt.org/pkgs/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devil exif freeimage geolocation graphicsmagick imagemagick mpv pdf raw"
+
+COMMON_DEPEND="
+ app-arch/libarchive:=
+ app-arch/unrar
+ dev-libs/pugixml
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[jpeg]
+ dev-qt/qtimageformats:5
+ dev-qt/qtmultimedia:5[qml]
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ devil? ( media-libs/devil )
+ exif? ( media-gfx/exiv2:=[bmff] )
+ freeimage? ( media-libs/freeimage )
+ geolocation? ( dev-qt/qtpositioning:5[qml] )
+ imagemagick? (
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ )
+ mpv? ( media-video/mpv:=[libmpv] )
+ pdf? ( app-text/poppler[qt5] )
+ raw? ( media-libs/libraw:= )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5
+"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCHROMECAST=OFF # TODO needs python
+ -DDEVIL=$(usex devil)
+ -DEXIV2=$(usex exif)
+ -DEXIV2_ENABLE_BMFF=$(usex exif)
+ -DFREEIMAGE=$(usex freeimage)
+ -DLOCATION=$(usex geolocation)
+ -DGRAPHICSMAGICK=$(usex graphicsmagick $(usex imagemagick))
+ -DIMAGEMAGICK=$(usex imagemagick $(usex !graphicsmagick))
+ -DVIDEO_MPV=$(usex mpv)
+ -DPOPPLER=$(usex pdf)
+ -DRAW=$(usex raw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ optfeature "additional image formats like AVIF, EPS, HEIF/HEIC, PSD, etc." kde-frameworks/kimageformats
+ ecm_pkg_postinst
+}