summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-03 16:02:43 -0400
committerSam James <sam@gentoo.org>2024-04-05 02:20:48 +0100
commite31da288a2f874bffb148a11ce0ef28eb0052d14 (patch)
treefd622b34df218c2b361dfc6d424ecfb2d2ca27e7 /media-gfx/openvdb
parentx11-apps/xdm: Version bump to 1.1.16 (diff)
downloadgentoo-e31da288a2f874bffb148a11ce0ef28eb0052d14.tar.gz
gentoo-e31da288a2f874bffb148a11ce0ef28eb0052d14.tar.bz2
gentoo-e31da288a2f874bffb148a11ce0ef28eb0052d14.zip
media-gfx/openvdb: mark as LTO-unsafe, strict-aliasing unsafe
Test-only issue, but this prevents testing that LTO actually works. ;) Closes: https://bugs.gentoo.org/926820 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/openvdb')
-rw-r--r--media-gfx/openvdb/openvdb-10.0.1.ebuild8
-rw-r--r--media-gfx/openvdb/openvdb-11.0.0.ebuild6
2 files changed, 13 insertions, 1 deletions
diff --git a/media-gfx/openvdb/openvdb-10.0.1.ebuild b/media-gfx/openvdb/openvdb-10.0.1.ebuild
index 287893b0cff4..5a0a42c5aed3 100644
--- a/media-gfx/openvdb/openvdb-10.0.1.ebuild
+++ b/media-gfx/openvdb/openvdb-10.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake cuda llvm python-single-r1
+inherit cmake cuda flag-o-matic llvm python-single-r1
DESCRIPTION="Library for the efficient manipulation of volumetric data"
HOMEPAGE="https://www.openvdb.org"
@@ -100,6 +100,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/926820
+ # https://github.com/AcademySoftwareFoundation/openvdb/issues/1784
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local myprefix="${EPREFIX}/usr/"
local version
diff --git a/media-gfx/openvdb/openvdb-11.0.0.ebuild b/media-gfx/openvdb/openvdb-11.0.0.ebuild
index 056d464f7218..35a71fe06c64 100644
--- a/media-gfx/openvdb/openvdb-11.0.0.ebuild
+++ b/media-gfx/openvdb/openvdb-11.0.0.ebuild
@@ -352,6 +352,12 @@ my_src_install() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/926820
+ # https://github.com/AcademySoftwareFoundation/openvdb/issues/1784
+ append-flags -fno-strict-aliasing
+ filter-lto
+
multibuild_foreach_variant my_src_configure
}