summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-21 19:37:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-21 20:14:54 +0100
commite4809498c27efa079b477bfcc80b32a403d5e594 (patch)
tree7a81a182c870e924b51018f3ed51dea52b597f20 /media-gfx/krita
parentwww-apps/element: drop 1.11.51, 1.11.52 (diff)
downloadgentoo-e4809498c27efa079b477bfcc80b32a403d5e594.tar.gz
gentoo-e4809498c27efa079b477bfcc80b32a403d5e594.tar.bz2
gentoo-e4809498c27efa079b477bfcc80b32a403d5e594.zip
media-gfx/krita: Fix build with >=media-libs/libjxl-0.9
Closes: https://bugs.gentoo.org/922524 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/krita')
-rw-r--r--media-gfx/krita/files/krita-5.1.5-libjxl-0.9.patch73
-rw-r--r--media-gfx/krita/krita-5.1.5.ebuild5
2 files changed, 76 insertions, 2 deletions
diff --git a/media-gfx/krita/files/krita-5.1.5-libjxl-0.9.patch b/media-gfx/krita/files/krita-5.1.5-libjxl-0.9.patch
new file mode 100644
index 000000000000..a578f22c67f9
--- /dev/null
+++ b/media-gfx/krita/files/krita-5.1.5-libjxl-0.9.patch
@@ -0,0 +1,73 @@
+From ace7edcca6ad322581ab39620f21ccf3ffbd3b5a Mon Sep 17 00:00:00 2001
+From: Timo Gurr <timo.gurr@gmail.com>
+Date: Fri, 5 Jan 2024 14:04:50 +0000
+Subject: [PATCH] Fix build with libjxl 0.9.0
+
+Fix build with libjxl 0.9.0
+
+BUG:478987
+
+Test Plan
+---------
+
+* Upgrade to libjxl 0.9.0
+* Apply patch from MR and build krita (5.2.2)
+* Open/Display a sample image e.g. https://jpegxl.info/test-page/red-room.jxl
+
+Formalities Checklist
+---------------------
+
+- [x] I confirmed this builds.
+- [x] I confirmed Krita ran and the relevant functions work (Could successfully open/display a sample image https://jpegxl.info/test-page/red-room.jxl).
+- [ ] I tested the relevant unit tests and can confirm they are not broken. (If not possible, don't hesitate to ask for help!)
+- [x] I made sure my commits build individually and have good descriptions as per [KDE guidelines](https://community.kde.org/Policies/Commit_Policy).
+- [x] I made sure my code conforms to the standards set in the HACKING file.
+- [x] I can confirm the code is licensed and attributed appropriately, and that unattributed code is mine, as per [KDE Licensing Policy](https://community.kde.org/Policies/Licensing_Policy).
+
+_**Reminder: the reviewer is responsible for merging the patch, this is to ensure at the least two people can build the patch. In case a patch breaks the build, both the author and the reviewer should be contacted to fix the build.**_
+_**If this is not possible, the commits shall be reverted, and a notification with the reasoning and any relevant logs shall be sent to the mailing list, kimageshop@kde.org.**_
+---
+ plugins/impex/jxl/JPEGXLImport.cpp | 15 ++++++++++++++-
+ 1 file changed, 14 insertions(+), 1 deletion(-)
+
+diff --git a/plugins/impex/jxl/JPEGXLImport.cpp b/plugins/impex/jxl/JPEGXLImport.cpp
+index 573bae41247..f5b989b3b70 100644
+--- a/plugins/impex/jxl/JPEGXLImport.cpp
++++ b/plugins/impex/jxl/JPEGXLImport.cpp
+@@ -511,7 +511,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
+ JxlColorEncoding colorEncoding{};
+ if (JXL_DEC_SUCCESS
+ == JxlDecoderGetColorAsEncodedProfile(dec.get(),
++#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0, 9, 0)
+ nullptr,
++#endif
+ JXL_COLOR_PROFILE_TARGET_DATA,
+ &colorEncoding)) {
+ const TransferCharacteristics transferFunction = [&]() {
+@@ -635,7 +637,12 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
+ size_t iccSize = 0;
+ QByteArray iccProfile;
+ if (JXL_DEC_SUCCESS
+- != JxlDecoderGetICCProfileSize(dec.get(), nullptr, JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
++ != JxlDecoderGetICCProfileSize(dec.get(),
++#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
++ nullptr,
++#endif
++ JXL_COLOR_PROFILE_TARGET_DATA,
++ &iccSize)) {
+ errFile << "ICC profile size retrieval failed";
+ document->setErrorMessage(i18nc("JPEG-XL errors", "Unable to read the image profile."));
+ return ImportExportCodes::ErrorWhileReading;
+@@ -643,7 +650,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
+ iccProfile.resize(static_cast<int>(iccSize));
+ if (JXL_DEC_SUCCESS
+ != JxlDecoderGetColorAsICCProfile(dec.get(),
++#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
+ nullptr,
++#endif
+ JXL_COLOR_PROFILE_TARGET_DATA,
+ reinterpret_cast<uint8_t *>(iccProfile.data()),
+ static_cast<size_t>(iccProfile.size()))) {
+--
+GitLab
+
diff --git a/media-gfx/krita/krita-5.1.5.ebuild b/media-gfx/krita/krita-5.1.5.ebuild
index ab68ac1db844..283b2c2e7a76 100644
--- a/media-gfx/krita/krita-5.1.5.ebuild
+++ b/media-gfx/krita/krita-5.1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,7 +70,7 @@ RDEPEND="${PYTHON_DEPS}
fftw? ( sci-libs/fftw:3.0= )
gif? ( media-libs/giflib )
gsl? ( sci-libs/gsl:= )
- jpegxl? ( >=media-libs/libjxl-0.7.0_pre20220825 )
+ jpegxl? ( >=media-libs/libjxl-0.7.0_pre20220825:= )
heif? ( >=media-libs/libheif-1.11:=[x265] )
mypaint-brush-engine? ( media-libs/libmypaint:= )
openexr? ( media-libs/openexr:= )
@@ -91,6 +91,7 @@ PATCHES=(
"${WORKDIR}/${P}-exiv2-0.28.patch" # bug 906472
"${FILESDIR}/${P}-ocio-2.3.0.patch" # bug 915107
"${FILESDIR}/${P}-sip-6.8.patch" # bug 919139
+ "${FILESDIR}/${P}-libjxl-0.9.patch" # bug 922524
)
pkg_setup() {