summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHector Martin <marcan@marcan.st>2021-01-04 17:22:12 +0900
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-15 21:25:03 +0100
commitb2757129ca25c1b7ff6e4e0095445c6650e2c5f0 (patch)
tree217259fa59d0c6ebfd2bc41d726a44bee646235a /media-gfx/iscan
parentapp-editors/pyvim: stable for amd64+x86. (diff)
downloadgentoo-b2757129ca25c1b7ff6e4e0095445c6650e2c5f0.tar.gz
gentoo-b2757129ca25c1b7ff6e4e0095445c6650e2c5f0.tar.bz2
gentoo-b2757129ca25c1b7ff6e4e0095445c6650e2c5f0.zip
media-gfx/iscan: fix build due to `bool` mismatch
Use <stdbool.h> instead of a custom bool type when available, to avoid build failures if other packages include <stdbool.h> later, which redefines it to _Bool. This causes build failures due to mismatch between declarations and definitions. Closes: https://bugs.gentoo.org/755884 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hector Martin <marcan@marcan.st> Closes: https://github.com/gentoo/gentoo/pull/18938 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/iscan')
-rw-r--r--media-gfx/iscan/files/iscan-2.30.4.2-c99.patch24
-rw-r--r--media-gfx/iscan/iscan-2.30.4.2-r1.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/media-gfx/iscan/files/iscan-2.30.4.2-c99.patch b/media-gfx/iscan/files/iscan-2.30.4.2-c99.patch
new file mode 100644
index 000000000000..93683c2887b4
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.30.4.2-c99.patch
@@ -0,0 +1,24 @@
+--- a/backend/defines.h 2021-01-04 08:13:48.995137756 -0000
++++ b/backend/defines.h 2021-01-04 08:16:00.524563361 -0000
+@@ -31,6 +31,13 @@
+
+
+ #ifndef __cplusplus
++
++/* Use the C99 bool type if available
++ */
++#ifdef HAVE_STDBOOL_H
++#include <stdbool.h>
++#else
++
+ /*! A C++ Boolean type and corresponding keywords for our C code.
+ */
+ typedef enum {
+@@ -38,6 +45,7 @@
+ true
+ } bool;
+ #endif
++#endif
+
+
+ /* Run-time contract validation.
diff --git a/media-gfx/iscan/iscan-2.30.4.2-r1.ebuild b/media-gfx/iscan/iscan-2.30.4.2-r1.ebuild
index 333d41b9b1c7..c1eb390986e3 100644
--- a/media-gfx/iscan/iscan-2.30.4.2-r1.ebuild
+++ b/media-gfx/iscan/iscan-2.30.4.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -70,6 +70,7 @@ PATCHES=(
"${FILESDIR}"/iscan-2.30.1.1-gcc6.patch
"${FILESDIR}"/iscan-2.30.3.1-fix-x86-unknown-types.patch
"${FILESDIR}"/iscan-2.30.4.2-sscanf.patch
+ "${FILESDIR}"/iscan-2.30.4.2-c99.patch
)
QA_PRESTRIPPED="usr/lib.*/libesmod.so.*"