summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-27 13:45:01 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-27 14:26:19 +0200
commitca00ec281351561204a22d2907583ec964e5ecae (patch)
tree7f3472e1d9971fd72d9234fed66b43fc44a80c8e /media-gfx/entangle
parentsys-cluster/kubeadm: Version bump to 1.15.4 (diff)
downloadgentoo-ca00ec281351561204a22d2907583ec964e5ecae.tar.gz
gentoo-ca00ec281351561204a22d2907583ec964e5ecae.tar.bz2
gentoo-ca00ec281351561204a22d2907583ec964e5ecae.zip
media-gfx/entangle: Bump to 2.0
Closes: https://bugs.gentoo.org/543308 Closes: https://bugs.gentoo.org/677158 Closes: https://bugs.gentoo.org/682250 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/entangle')
-rw-r--r--media-gfx/entangle/Manifest1
-rw-r--r--media-gfx/entangle/entangle-2.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-gfx/entangle/Manifest b/media-gfx/entangle/Manifest
index 0c23f9d36bd7..252e0485b25c 100644
--- a/media-gfx/entangle/Manifest
+++ b/media-gfx/entangle/Manifest
@@ -1 +1,2 @@
DIST entangle-0.6.0.tar.gz 906858 BLAKE2B 18a35ef7e077f5929846127e06bff2d07b61c5409d2957b421d8ec5466f29483b6fc7d5567cd057e2b44ef4147ed962e267e7e5509ef6640582b5d291a7f79f3 SHA512 f96718f01286eb0dbf1fafd4d51258bda876a5b22a6167173f0f60b4fe00683baff3d4c8f9866a5dc1eec493e2b25fd932794a63a8a8d102cb220b1d6ea8e960
+DIST entangle-2.0.tar.xz 501912 BLAKE2B b7e1c393dc95d66bf4389c607c0eb6eb70161ceb2c845135c7c99313a1ec13388c6b00fd6ed7f38ad6f9f18d8c97eba0aadab7964d1be8ec03373e5598374796 SHA512 be8b75c5dd0bdd7cd380f35b5d46d7be9f7caa2be257ce954cf9516ebd5601071ac8b50838f9c40470b6e3e5f95083c3671af68ac43eb345a60d674636a0fe86
diff --git a/media-gfx/entangle/entangle-2.0.ebuild b/media-gfx/entangle/entangle-2.0.ebuild
new file mode 100644
index 000000000000..1d719a1b3d2d
--- /dev/null
+++ b/media-gfx/entangle/entangle-2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit gnome2-utils meson python-single-r1 xdg-utils
+
+DESCRIPTION="Tethered Camera Control & Capture"
+HOMEPAGE="https://entangle-photo.org/"
+SRC_URI="https://entangle-photo.org/download/sources/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/gobject-introspection-1.54.0
+ >=dev-libs/libpeas-1.2.0[gtk,${PYTHON_USEDEP}]
+ >=media-libs/gexiv2-0.10[introspection]
+ >=media-libs/libgphoto2-2.5.0:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/lcms:2
+ >=media-libs/libraw-0.9.0
+ >=x11-libs/gdk-pixbuf-2.12.0:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=x11-libs/libXext-1.3.0
+ x11-themes/adwaita-icon-theme
+ virtual/libgudev:="
+RDEPEND="${DEPEND}"
+
+# perl for pod2man
+BDEPEND="
+ app-text/yelp-tools
+ dev-lang/perl
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_compile() {
+ # prevent gst from loading system plugins which causes
+ # sandbox violations on device access
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}