summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/apngdis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/apngdis')
-rw-r--r--media-gfx/apngdis/Manifest1
-rw-r--r--media-gfx/apngdis/apngdis-2.7.ebuild35
-rw-r--r--media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch10
-rw-r--r--media-gfx/apngdis/files/apngdis-2.6-makefile.patch17
-rw-r--r--media-gfx/apngdis/metadata.xml8
5 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/apngdis/Manifest b/media-gfx/apngdis/Manifest
new file mode 100644
index 000000000000..33461dac107a
--- /dev/null
+++ b/media-gfx/apngdis/Manifest
@@ -0,0 +1 @@
+DIST apngdis-2.7-src.zip 450869 SHA256 cce7470d1ec0c518655d63133931e16d01050033405b67220e94ca7b2b97920d SHA512 016c9f0fe1ed7a26f9982414ea797b7a1f1b854ea9d13d089f0fbf9886520b637dc3dd0a7968137db4055f039afb1a5015fa2d1611b48ebb2e98af1b8e3c56fb WHIRLPOOL f9b7360da201de55a86f45decb265d9b71227c4ce6441d8faeb2d6d9211dca8d3da7f76f5e6dd66e8f3f61ddd9d58cb66afddac451dad7a1ec9fbec2080687ed
diff --git a/media-gfx/apngdis/apngdis-2.7.ebuild b/media-gfx/apngdis/apngdis-2.7.ebuild
new file mode 100644
index 000000000000..9584e99cac35
--- /dev/null
+++ b/media-gfx/apngdis/apngdis-2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="extract PNG frames from an APNG"
+HOMEPAGE="http://sourceforge.net/projects/apngdis/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6-makefile.patch
+ epatch "${FILESDIR}"/${PN}-2.6-gcc-4.3.patch
+
+ tc-export CXX
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch b/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch
new file mode 100644
index 000000000000..cabf3efed742
--- /dev/null
+++ b/media-gfx/apngdis/files/apngdis-2.6-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- apngdis-2.6-src/apngdis.cpp
++++ apngdis-2.6-src/apngdis.cpp
+@@ -29,6 +29,7 @@
+ */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+ #include <vector>
+ #include "png.h" /* original (unpatched) libpng is ok */
+ #include "zlib.h"
diff --git a/media-gfx/apngdis/files/apngdis-2.6-makefile.patch b/media-gfx/apngdis/files/apngdis-2.6-makefile.patch
new file mode 100644
index 000000000000..ada1cc89a23f
--- /dev/null
+++ b/media-gfx/apngdis/files/apngdis-2.6-makefile.patch
@@ -0,0 +1,17 @@
+--- apngdis-2.6-src/Makefile
++++ apngdis-2.6-src/Makefile
+@@ -1,11 +1,10 @@
+ PACKAGE = apngdis
+-CC = gcc
+-CFLAGS = -Wall -pedantic
+-CFLAGS_OPT = -O2
++CCX ?= g++
++CFLAGS += -Wall -pedantic
+ LIBS = -lstdc++ -lm -lpng -lz
+
+ all :
+- $(CC) $(CFLAGS) $(CFLAGS_OPT) -o apngdis apngdis.cpp -s $(LIBS)
++ $(CXX) $(CFLAGS) $(LDFLAGS) -o apngdis apngdis.cpp $(LIBS)
+
+ .PHONY : clean
+
diff --git a/media-gfx/apngdis/metadata.xml b/media-gfx/apngdis/metadata.xml
new file mode 100644
index 000000000000..dd79e90cbe52
--- /dev/null
+++ b/media-gfx/apngdis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <remote-id type="sourceforge">apngdis</remote-id>
+ </upstream>
+</pkgmetadata>