summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-05-16 11:03:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 19:46:51 +0300
commit87a269dc971e1db93daaecf5070b415ebdd29e35 (patch)
treec44684c7ca313bc07bb86af03a7424c60e065826 /media-gfx/alembic
parentnet-dns/openresolv: move DOCS array in 3.10.0 (diff)
downloadgentoo-87a269dc971e1db93daaecf5070b415ebdd29e35.tar.gz
gentoo-87a269dc971e1db93daaecf5070b415ebdd29e35.tar.bz2
gentoo-87a269dc971e1db93daaecf5070b415ebdd29e35.zip
media-gfx/alembic: bump to 1.7.12
Thanks to @redchillipadi for providing the initial ebuild. Remove arnold and maya USE flags due to not being able to test these. Note: The package supports Python 3, but depends on >=pyilmbase-2.4.1 for it to work, c.f. https://bugs.gentoo.org/711456 and PR #14832. For this, I'm not closing bug #717564. Thanks-to: Adrian Grigo <agrigo2001@yahoo.com.au> Bug: https://bugs.gentoo.org/711456 Bug: https://bugs.gentoo.org/717564 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.7.12.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 84ee0347aaa8..21dfd5883004 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.7.11.tar.gz 826833 BLAKE2B ea2ee92cefcc92d3658b8c71351ec0f72bd1fb5d5b6c771ceebe81b1db61a280420f480cd3612f44bc134cccb388954be89baba9dc6e5973e102bc55d65cd974 SHA512 94b9c218a2fe6e2e24205aff4a2f6bab784851c2aa15592fb60ea91f0e8038b0c0656a118f3a5cba0d3de8917dd90b74d0e2d1c4ac034b9ee3f5d0741d9f6b70
+DIST alembic-1.7.12.tar.gz 827983 BLAKE2B 7d508fdbfd92f213936635666a221fdad30f242a37ef8ff54a6272854565ebb890ffd11d8fe010f1558c0872fcb23080413d76380772ebf5db52033bdf0d9c85 SHA512 e05e0b24056c17f01784ced1f9606a269974de195f1aca8a6fce2123314e7ee609f70df77ac7fe18dc7f0c04fb883d38cc7de9b963caacf9586aaa24d4ac6210
DIST alembic-1.7.9.tar.gz 813379 BLAKE2B 599edeb5ad805656755b3e150fba56182d1d60673951b0c1702b3e3e82d9499ec4fcb938303103c27f84458f61ab8de4b872eaa322380ae7713e3b4cd3831af7 SHA512 8025c20525ffbd5bdc9dd5a33ad8238e49f063d244ab9d112e7d1ddb7ee7cf9b36ceb74cb45d658ce22d3033552c89bddf6b818cf466ea46aa1a70a41fdeddb2
diff --git a/media-gfx/alembic/alembic-1.7.12.ebuild b/media-gfx/alembic/alembic-1.7.12.ebuild
new file mode 100644
index 000000000000..47fd6c0a0341
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.7.12.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake multiprocessing python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boost doc examples hdf5 prman python test zlib"
+RESTRICT="!test? ( test )"
+
+# pyalembic python bindings need boost
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ hdf5? ( zlib )
+ python? ( boost )
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=media-libs/openexr-2.3.0:=
+ hdf5? ( >=sci-libs/hdf5-1.10.2:=[zlib(+)] )
+ python? ( >=dev-python/pyilmbase-2.3.0[${PYTHON_SINGLE_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.11-r1 )
+ $(python_gen_cond_dep '
+ boost? ( >=dev-libs/boost-1.65.0:=[python?,${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.8.14-r1 )
+"
+
+DOCS=( "ACKNOWLEDGEMENTS.txt" "FEEDBACK.txt" "NEWS.txt" "README.txt" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.11-0001-Fix-to-find-boost-with-cmake-3.11.patch"
+ "${FILESDIR}/${PN}-1.7.11-0002-Find-IlmBase-by-setting-a-proper-ILMBASE_ROOT-value.patch"
+ "${FILESDIR}/${PN}-1.7.11-0003-Fix-env-var-for-renderman.patch"
+ "${FILESDIR}/${PN}-1.7.11-0004-Fix-a-compile-issue-with-const.patch"
+ "${FILESDIR}/${PN}-1.7.11-0005-Fix-install-locations.patch"
+ "${FILESDIR}/${PN}-1.7.11-0006-python-PyAlembic-Tests-CMakeLists.txt-fix-variable.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ if use doc; then
+ doxygen -u Doxyfile || die "Failed to update Doxyfile"
+ sed -i -e 's|DOT_NUM_THREADS[ \t]*= 0|DOT_NUM_THREADS = '$(makeopts_jobs)'|' Doxyfile || die "Failed to change dot threads"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_SHARED_LIBS=ON
+ # The CMakeLists.txt file needs C++11 or C++-0x if none of them
+ # is defined
+ -DALEMBIC_LIB_USES_BOOST=$(usex boost)
+ -DALEMBIC_LIB_USES_TR1=$(usex !boost)
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=$(usex prman)
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ doxygen Doxyfile || die "Failed to build documentation"
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ cmake_src_install
+}
+
+pkg_postinst() {
+ if use prman; then
+ einfo "If you're looking for an ebuild for renderman, you may want to"
+ einfo "try the waebbl overlay: 'eselect repository enable waebbl'"
+ einfo "followed by 'emerge renderman'"
+ fi
+}