summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-11-08 19:07:06 +0100
committerPacho Ramos <pacho@gentoo.org>2024-11-08 19:16:06 +0100
commit3b642ee0b000fefc9881ff9e85943bd9121e314e (patch)
tree2a3c666a46ca02af5556e5504955777cc276a7f3 /media-fonts
parentapp-i18n/poedit: unkeyword 3.5.2 for ~hppa, ~sparc (diff)
downloadgentoo-3b642ee0b000fefc9881ff9e85943bd9121e314e.tar.gz
gentoo-3b642ee0b000fefc9881ff9e85943bd9121e314e.tar.bz2
gentoo-3b642ee0b000fefc9881ff9e85943bd9121e314e.zip
media-fonts/noto: add 20241101
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/noto/Manifest1
-rw-r--r--media-fonts/noto/noto-20241101.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-fonts/noto/Manifest b/media-fonts/noto/Manifest
index 386a7d949914..ae33c18d44dc 100644
--- a/media-fonts/noto/Manifest
+++ b/media-fonts/noto/Manifest
@@ -1,3 +1,4 @@
DIST noto-20240630.tar.gz 1089432282 BLAKE2B 07984ab5deb385855122bd1688b237ef2c59956e7516db16f4ed2b683b1c04ae73c06bc4e5ba766077fb479e774a38a6ab97a318299b0581032dedb9ad7c3cc0 SHA512 eb0a0416c2a12b1a37f867d0f13a55d1d169466786fd367de246c67008c5def9c49eb942e81aaf9810f5c071cca076fa9019b92b11e169a48fe0b15dc7ce43aa
DIST noto-20240731.tar.gz 1087189796 BLAKE2B 939cc60437521166c01c7255c23e33fa29d8eebd186191bde8bc79a3b9a27c25e9b393af92a55926b398f8540da2c676cda3720d844689d38b029397620e4c88 SHA512 0361b602f6e9545ffdcae85674f8d3bec1235cec506a271a5f857f80f339562972461dc70d89ebf0dce42bb13235e0b59c0b121292983843534cb489c69b4218
DIST noto-20240830.tar.gz 1087158158 BLAKE2B e3b3410fa3c3fbd48e3224f7a22a46377ffa50d36df4027902bd86949579d33ebfb883939feba62ce8520a10d1c982c0c600e7363d5e3a752e76d75059eedf5b SHA512 cf3ac08d2c1fb134194ce6b1211d63ab5fc00adcfc92106afdd872ad9fb75cbf0437d88314a8cc3681fa93974f37c736685f529231ad5e8f8eca429876ee0032
+DIST noto-20241101.tar.gz 1086999253 BLAKE2B 237d96dcd89ed86c6edfb3316d420eb7ca00a4486a7bb54087896330d21ee87307c16b6991b897eb87459c3f0fa1739f879347c9c24f1ef1f2aa953c2051a3a8 SHA512 dfc31ebe3cd5947182ac771e1bcbbc7cd3a1b56b5a9aa74a0fcc94ff6a5060a3cb8bc57a01587d955fc7505e566dd3a7283d7fd521c839b264e55ca2c9297c13
diff --git a/media-fonts/noto/noto-20241101.ebuild b/media-fonts/noto/noto-20241101.ebuild
new file mode 100644
index 000000000000..e6359fd9f72d
--- /dev/null
+++ b/media-fonts/noto/noto-20241101.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://fonts.google.com/noto https://github.com/notofonts/notofonts.github.io"
+
+COMMIT="3b76d79d8ac2da795061b67c9b6db159fd023d5a"
+SRC_URI="https://github.com/notofonts/notofonts.github.io/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/notofonts.github.io-${COMMIT}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://fonts.google.com/noto
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+
+RESTRICT="binchecks strip"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-hinted || die
+ mv fonts/*/hinted/ttf/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.tt[f,c]
+}