summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 01:56:22 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:39 +0000
commit21fd371e879f2c4ee61b509ae287643ecb3356a7 (patch)
tree4627f5a914c4962646fcc374485aac052c829598 /mate-base
parentmate-base/mate-applets-meta: add 1.27.1 (diff)
downloadgentoo-21fd371e879f2c4ee61b509ae287643ecb3356a7.tar.gz
gentoo-21fd371e879f2c4ee61b509ae287643ecb3356a7.tar.bz2
gentoo-21fd371e879f2c4ee61b509ae287643ecb3356a7.zip
mate-base/mate-common: add 1.27.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-common/Manifest1
-rw-r--r--mate-base/mate-common/mate-common-1.27.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/mate-base/mate-common/Manifest b/mate-base/mate-common/Manifest
index 1b3196f2c476..7951f9c7a27b 100644
--- a/mate-base/mate-common/Manifest
+++ b/mate-base/mate-common/Manifest
@@ -1,2 +1,3 @@
DIST mate-common-1.26.0.tar.xz 69604 BLAKE2B 73c4b065eba0287d3f16ec3fdff8145dd97b765283f4017b31a7b86cb45949a4f7dde0207c244dc5c8047570830b85714955c23165889ae994a566f2f00a752c SHA512 9bfde79c9243d394f9ebc743f6a3c27199ec1e857f80020be0ff8b64a48cf1183fffd88783c1d375f2983a32c7437ca49b2f03b3e844e147c5750f71dbfb93bd
DIST mate-common-1.27.0.tar.xz 70444 BLAKE2B 670f6ffad51abd2786171206fdf1636b92a99704617b6fb96a2a3b95dd29ea0958a2795b5a83dd4aa2d29a39125915128b898c47d6e5c1bc51e84b49c3089fe3 SHA512 45e301982090a6ed37d04bf351cc9d5a61d37b52e9ca2732d9186918f05cb4d1a413d8837161e6c02e90d0fb90e6bc23fc73ffee04a8695cb3b121909b7ea812
+DIST mate-common-1.27.1.tar.xz 70492 BLAKE2B 5a9766d71f749bfae00e742e647dcfa0d34a971f9d63a9aa6c2ed608b1fc2ac65e9221b5d70ed5162c17b5d92ef819b544d2f05d98d14723583e9b6dde8d821c SHA512 91f63c3f3317bea78e9413021dc96269feb2d9e0e1572d72bb7f2b3da62a20ea1f32269b7c2e54645f31bd16d84f1b3ae6858f8476ad92cb7503e31957f10635
diff --git a/mate-base/mate-common/mate-common-1.27.1.ebuild b/mate-base/mate-common/mate-common-1.27.1.ebuild
new file mode 100644
index 000000000000..43421c4e45e3
--- /dev/null
+++ b/mate-base/mate-common/mate-common-1.27.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate-desktop.org
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Common files for development of MATE packages"
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ fi
+}
+
+src_install() {
+ mv doc-build/README README.doc-build \
+ || die "Failed to rename doc-build/README."
+
+ default
+
+ dodoc doc/usage.txt
+}