summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-11 11:56:59 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-11 12:29:47 +0100
commitf2390c37778529fbe9f6c61f3ca03ba5e4176d14 (patch)
tree408cbda5fba1ce26cce8cee985aff8ecd63e24b2 /llvm-core
parentllvm-runtimes/offload: Add 21.0.0_pre20250211 snapshot (diff)
downloadgentoo-f2390c37778529fbe9f6c61f3ca03ba5e4176d14.tar.gz
gentoo-f2390c37778529fbe9f6c61f3ca03ba5e4176d14.tar.bz2
gentoo-f2390c37778529fbe9f6c61f3ca03ba5e4176d14.zip
llvm-core/clang-runtime: Add 21.0.0_pre20250211 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core')
-rw-r--r--llvm-core/clang-runtime/clang-runtime-21.0.0_pre20250211.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/llvm-core/clang-runtime/clang-runtime-21.0.0_pre20250211.ebuild b/llvm-core/clang-runtime/clang-runtime-21.0.0_pre20250211.ebuild
new file mode 100644
index 000000000000..542c7b28a6f4
--- /dev/null
+++ b/llvm-core/clang-runtime/clang-runtime-21.0.0_pre20250211.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+IUSE="+compiler-rt libcxx offload openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? (
+ >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
+ offload? (
+ >=llvm-runtimes/offload-${PV}
+ )
+ )
+"