summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-16 10:59:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-16 15:37:17 +0100
commit3b5772b2fc664c0667daec129b604096f6dd468f (patch)
tree3eaed63ef3cf92127b66b8241d02dba03a87ebcb /kde-plasma
parentkde-plasma/ksysguard: 5.21.0 version bump (diff)
downloadgentoo-3b5772b2fc664c0667daec129b604096f6dd468f.tar.gz
gentoo-3b5772b2fc664c0667daec129b604096f6dd468f.tar.bz2
gentoo-3b5772b2fc664c0667daec129b604096f6dd468f.zip
kde-plasma/kwallet-pam: 5.21.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.21.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 57e812501d64..5b7e98e55a9d 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.20.5.tar.xz 19812 BLAKE2B d0ad931e47a35b5589e9c34bce924f697446460bcfbfcceb4e3f0564182bbac822f13488dddc592f7b6a119d774b6176b86df8ddca55fb0c9423d0c7634fa9cc SHA512 5f728c2fbbcbfa7a2b50a2d9b60e557360b48d6a5958ce290ace3e2ae8c253b56f64178942f958d38e7e62e0baf1cad0ddb2aa28e11d145f3b507d58900dcb03
+DIST kwallet-pam-5.21.0.tar.xz 19892 BLAKE2B c38e20335db1c26620b6e93bbcf0f3481188e55acf1b7dd400418a63e8cde736b5d770adfe2cd78dad3213d972263fc14a224c077ee6d34e7ec14bb2fdc9e148 SHA512 5aefbb97267033251d93627cc89f7af4fb33ab3d9c348937fb36a445a2fb09f762747d28c29693569ad2cca474c04b4b4fb612e961f40ea209fc13fcf01b660e
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.21.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.21.0.ebuild
new file mode 100644
index 000000000000..8a587a1fcf29
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.21.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.78.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}