summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 12:44:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-28 14:52:32 +0100
commitab1a069c5ac868859ccdb39ad4da530ac9a2d88d (patch)
treeab3c2cf43eb18e1e18d0f04364b1a94f3f6ef434 /kde-plasma/plasma-nm
parentkde-plasma/plasma-meta: 6.0.0 version bump (diff)
downloadgentoo-ab1a069c5ac868859ccdb39ad4da530ac9a2d88d.tar.gz
gentoo-ab1a069c5ac868859ccdb39ad4da530ac9a2d88d.tar.bz2
gentoo-ab1a069c5ac868859ccdb39ad4da530ac9a2d88d.zip
kde-plasma/plasma-nm: 6.0.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-6.0.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 8801d29d96dc..b85d121b4ffd 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.27.10.tar.xz 1155856 BLAKE2B e3633156c65991aa938ab60b429dd56f7f78a2ae49b7cbe2b21a8cfba6eefb2b490b69d540fbc4b62017b3ae28186eade08f93c059f2ec20ed4fa5946731095e SHA512 427e6b8ebcd471c0e09a483e43207e60367dae45f8d7727101559685fb9e8f5eaa1a6328a5fd6af4f0a39e7533495ed5402f2f34be9fa943099906d092b1739d
DIST plasma-nm-5.93.0.tar.xz 1178220 BLAKE2B e70ba27854eb34c100308163d340103bb356aa78564d9b787a20aba8373fbfd088b16254be5c76e7d13e4cc5a38b0d3f44a92fefd03ed64690625f16d7b4b091 SHA512 d524cda056b1d0c727c6a6bc7bd963ecaa5fb66ee9e54a5a3f8dcc971da1ccc89946e321edd8e2da0336775d5379989d874c0b3dd18716a3e26522006b43ec4a
+DIST plasma-nm-6.0.0.tar.xz 1170532 BLAKE2B e990a5a7b1404f9d5fb36c71656abb3fadb1e8f981226a21300af818b0bfe2c9583c31200bb5e1c07269493d0d98dc74c2703b88b519895f63451e2175bac52d SHA512 c0bc99cfcb2b81d1bba9b7dbf4890a8cc08005c08b0cec5b7b16d279fd7f300adb6e141ce491ba9e2e0b5adb2e98c5c302c9735f58c53214abedd384ed81d593
diff --git a/kde-plasma/plasma-nm/plasma-nm-6.0.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-6.0.0.ebuild
new file mode 100644
index 000000000000..ebef5ede78f0
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-6.0.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="openconnect teamd"
+
+DEPEND="
+ >=app-crypt/qca-2.3.7:2[qt6]
+ dev-libs/qcoro[dbus]
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/ksvg-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/modemmanager-qt-${KFMIN}:6
+ >=kde-frameworks/networkmanager-qt-${KFMIN}:6[teamd=]
+ >=kde-frameworks/solid-${KFMIN}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ net-misc/mobile-broadband-provider-info
+ net-misc/networkmanager[teamd=]
+ openconnect? (
+ >=dev-qt/qtwebengine-${QTMIN}:6
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/kquickcharts-${KFMIN}:6
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+"
+BDEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_OPENCONNECT=$(usex openconnect)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! has_version "kde-frameworks/kcmutils:6"; then
+ elog "${PN} is not terribly useful without kde-frameworks/kcmutils:6."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell6 kcm_networkmanagement"
+ fi
+}