summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 16:03:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 16:46:20 +0100
commitc7b30a04d4d8d2196b7541be0634660c2ae610f4 (patch)
tree1b9bbf369af7d9636187105d04d42b6f48e5ca18 /kde-plasma/kwayland-integration
parentkde-plasma/kwayland: 6.0.1 version bump (diff)
downloadgentoo-c7b30a04d4d8d2196b7541be0634660c2ae610f4.tar.gz
gentoo-c7b30a04d4d8d2196b7541be0634660c2ae610f4.tar.bz2
gentoo-c7b30a04d4d8d2196b7541be0634660c2ae610f4.zip
kde-plasma/kwayland-integration: 6.0.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-integration')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-6.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index 35593562410e..1ff4672db965 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1,2 +1,3 @@
DIST kwayland-integration-5.27.10.tar.xz 25776 BLAKE2B dbd1b2cedf1128f59318e41036bde63c8062538804a6b26418bce2210860a0b0f1dcbf217f9b823924ec8865b2bc3d6ceae7a06339d8ea1a508d67763e697027 SHA512 c66b08ba2af7675add7d603e0b8bdd20578abfc71af15574c389c8bec9856f309fe856c236f9fc8832e38c0125f5d55a3cc3d649b9d49733ee93d656b9c293fe
DIST kwayland-integration-6.0.0.tar.xz 26400 BLAKE2B 863bd95e98b1fa1a6d9b839dc1a66cfc972abb2b3c4c85bd357f5d8ecef24aa730277f536340b6a577f9eb271c910301c704f15410fd00be09c1c816bad69e42 SHA512 1e351dbc2b81d990f69a7867d428cf2ec167af6c0553100b7e759f19353d8df45310536266365ef0fe37c4399a434a969f61de9cd257cd9b151e1bdaa8b109f4
+DIST kwayland-integration-6.0.1.tar.xz 26420 BLAKE2B 09e7e0479de0f8227fbd54a6bb057b569a60617db955b32de9de80bbd8791ff9873eb37954e7e4acdfa281208d3e30c1518340f1579f99ade4c18d1bf892e10d SHA512 55728eb0f6a40a643d66efa96cd80a2a5d9ae3f59425bd2823556c09d4eb1c54583bcf19121679932b11f71b5946fd3fc3718a70ca11d684c7a44e637e9a42a2
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-6.0.1.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-6.0.1.ebuild
new file mode 100644
index 000000000000..058fb471a0da
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-6.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.113.0
+QTMIN=5.15.9
+inherit ecm flag-o-matic plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ filter-lto # bug 921430
+ ecm_src_configure
+}