summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-18 16:25:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-18 18:11:40 +0200
commitdd8e6c848a97aea2c41c5c69bc0aa5585722e39c (patch)
tree9b0bb4507fb9ec18c0af393f5d98e0e15b7eeba2 /kde-plasma/kinfocenter
parentnet-misc/cadaver: Add ${EPREFIX}. (diff)
downloadgentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.tar.gz
gentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.tar.bz2
gentoo-dd8e6c848a97aea2c41c5c69bc0aa5585722e39c.zip
kde-plasma: Add KDE Plasma 5.16.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.16.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 20d8f10845ed..f24a3b3f3ea1 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.15.5.tar.xz 1321684 BLAKE2B 51a3b49a5b724d187f58513c87f0618b1ee71d00e4ed51019017ae427602b7135d6bd9419714c431e3440f8a27152c4a72951d929b727f200c5cf1d72fc3ac84 SHA512 d75561edc65701097e4c9249f1cb7208e14ee1e99acbd6521606c99ac8e4ebe9ab42a804d8ef7bcde138d3189e3dbd9aaad088563ae6364418e6119639ac3974
DIST kinfocenter-5.16.0.tar.xz 1322544 BLAKE2B cd178d65a195ae9e678864dd3d4a93b761446edc5aa34765641972f9452a02cab2cebbba1f17f9ba181f3dc39c3e9db47396622e80addd6886305340469f36b9 SHA512 13729a7417b07a746eadb21e6ac17b793d64f38c24551ff67ebba899932bdca1f860195ea8647b3cdb962367b547b9c85c5966b8f6c575da3eddf6adc41e87cb
+DIST kinfocenter-5.16.1.tar.xz 1322776 BLAKE2B fe75260eb57fe38231e6db4627d44dfff1bf34b4cb80ee886a5dbad02f6561ff061e55a0dd0598d142fa62716814d491f7d8f9b3d9bac877852e2c1d34b56465 SHA512 0515061a22950e3ffaa54364d163e9575dce10abdea3f4e46daa57ddf238eb6a58d967fa2f56e3a1ebebc118f3d58b80898c0abccd51078e8e94d347418d7815
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.16.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.16.1.ebuild
new file mode 100644
index 000000000000..084102a9d35d
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.16.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MIN_VERSION=3.14.3
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ $(add_qt_dep qtquickcontrols2)
+ !kde-apps/kcontrol:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ if has_version "dev-qt/qtgui[gles2]"; then
+ mycmakeargs+=( $(cmake-utils_use_find_package gles2 OpenGLES) )
+ else
+ mycmakeargs+=( $(cmake-utils_use_find_package opengl OpenGL) )
+ fi
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ has_version "net-fs/nfs-utils" || \
+ elog "Installing net-fs/nfs-utils will enable the NFS information module."
+
+ has_version "net-fs/samba" || \
+ elog "Installing net-fs/samba will enable the Samba status information module."
+ fi
+}