summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kim4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kim4')
-rw-r--r--kde-misc/kim4/Manifest1
-rw-r--r--kde-misc/kim4/files/kim4-0.9.5-install.sh.patch39
-rw-r--r--kde-misc/kim4/kim4-0.9.5.ebuild36
-rw-r--r--kde-misc/kim4/metadata.xml5
4 files changed, 81 insertions, 0 deletions
diff --git a/kde-misc/kim4/Manifest b/kde-misc/kim4/Manifest
new file mode 100644
index 000000000000..5ed9339c158e
--- /dev/null
+++ b/kde-misc/kim4/Manifest
@@ -0,0 +1 @@
+DIST kim4-0.9.5.tar.gz 53171 SHA256 85c89695f30227413d6229b1f9c7f75b85a1e73d24d3c9479af40c52b76b6dac SHA512 db53ad97c6bbfe48eb0d949a0c35ef1aeae6d190c595b93d101bd8248a623bb06dc56786c75260eeb6574d8f26f86f625fe91ef1d038881bb92e22e475288a9f WHIRLPOOL 13f76ac01f030ca1d7def7a3702ee895afd6498015cb991a8deb20ec6e348e602277e578b76287a318116e128c92cfd3aaa2da2ca7188ffdbf04dead8d54ef33
diff --git a/kde-misc/kim4/files/kim4-0.9.5-install.sh.patch b/kde-misc/kim4/files/kim4-0.9.5-install.sh.patch
new file mode 100644
index 000000000000..042b0a17107e
--- /dev/null
+++ b/kde-misc/kim4/files/kim4-0.9.5-install.sh.patch
@@ -0,0 +1,39 @@
+--- install.sh.orig 2009-02-22 18:08:21.000000000 +0200
++++ install.sh 2009-10-29 00:00:04.000000000 +0200
+@@ -19,19 +19,22 @@
+
+ kdeinstdir=`kde4-config --prefix`
+
+-cp src/kim_*.desktop $kdeinstdir/share/kde4/services/ServiceMenus/
+-cp src/bin/kim_* $kdeinstdir/bin/
+-chmod a+rx $kdeinstdir/bin/kim_*
+-chmod a+r $kdeinstdir/share/kde4/services/ServiceMenus/kim_*.desktop
+-mv $kdeinstdir/share/kde4/services/ServiceMenus/imageconverter.desktop $kdeinstdir/share/kde4/services/ServiceMenus/imageconverter.desktop~
+-
+-mkdir $kdeinstdir/share/kim
+-cp COPYING $kdeinstdir/share/kim/kim_about.txt
++mkdir -p ${DESTDIR}$kdeinstdir/share/kde4/services/ServiceMenus
++cp src/kim_*.desktop ${DESTDIR}$kdeinstdir/share/kde4/services/ServiceMenus/
+
+-mkdir $kdeinstdir/share/kim/slideshow/
+-cp src/slideshow/* $kdeinstdir/share/kim/slideshow/
++mkdir -p ${DESTDIR}$kdeinstdir/bin
++cp src/bin/kim_* ${DESTDIR}$kdeinstdir/bin/
+
+-mkdir $kdeinstdir/share/kim/gallery
+-cp src/gallery/* $kdeinstdir/share/kim/gallery
++chmod a+rx ${DESTDIR}$kdeinstdir/bin/kim_*
++chmod a+r ${DESTDIR}$kdeinstdir/share/kde4/services/ServiceMenus/kim_*.desktop
+
+-echo "Kim has been installed. Good bye!"
+\ No newline at end of file
++mkdir -p ${DESTDIR}$kdeinstdir/share/apps/kim
++cp COPYING ${DESTDIR}$kdeinstdir/share/apps/kim/kim_about.txt
++
++mkdir -p ${DESTDIR}$kdeinstdir/share/kim/slideshow
++cp src/slideshow/* ${DESTDIR}$kdeinstdir/share/kim/slideshow/
++
++mkdir -p ${DESTDIR}$kdeinstdir/share/kim/gallery
++cp src/gallery/* ${DESTDIR}$kdeinstdir/share/kim/gallery
++
++echo "Kim has been installed. Good bye!"
diff --git a/kde-misc/kim4/kim4-0.9.5.ebuild b/kde-misc/kim4/kim4-0.9.5.ebuild
new file mode 100644
index 000000000000..af99aec669a8
--- /dev/null
+++ b/kde-misc/kim4/kim4-0.9.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A Dolphin and Konqueror service menu for ImageMagick"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/Kim+%28Kde+Image+Menu%29?content=11505"
+SRC_URI="http://bouveyron.free.fr/kim/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+RDEPEND="
+ kde-apps/kdialog
+ || (
+ kde-apps/dolphin
+ kde-apps/konqueror
+ )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.sh.patch
+}
+
+src_install() {
+ DESTDIR=${D} ./install.sh || die
+ dodoc AUTHORS ChangeLog README || die
+}
diff --git a/kde-misc/kim4/metadata.xml b/kde-misc/kim4/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/kim4/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>