summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 11:13:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 12:07:51 +0100
commit259a5f4e6ef30f04c535eadefbc5422fd22a4a24 (patch)
treef5033a16ee273d692220311d6d80e10c6c795845 /kde-frameworks
parentkde-frameworks/kdeclarative: Drop 5.88.0 (r0) (diff)
downloadgentoo-259a5f4e6ef30f04c535eadefbc5422fd22a4a24.tar.gz
gentoo-259a5f4e6ef30f04c535eadefbc5422fd22a4a24.tar.bz2
gentoo-259a5f4e6ef30f04c535eadefbc5422fd22a4a24.zip
kde-frameworks/ktexteditor: Revert "completion: invoke always"
Regression from KF 5.87, see also: https://invent.kde.org/frameworks/ktexteditor/-/merge_requests/224 Upstream commit 3be743ebd34cfb1992d52ffe38ac5512e36aae12 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=444883 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-5.88.0-revert-invoke-always.patch36
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-5.88.0-r1.ebuild63
2 files changed, 99 insertions, 0 deletions
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-5.88.0-revert-invoke-always.patch b/kde-frameworks/ktexteditor/files/ktexteditor-5.88.0-revert-invoke-always.patch
new file mode 100644
index 000000000000..543a2f8e0a65
--- /dev/null
+++ b/kde-frameworks/ktexteditor/files/ktexteditor-5.88.0-revert-invoke-always.patch
@@ -0,0 +1,36 @@
+From 3be743ebd34cfb1992d52ffe38ac5512e36aae12 Mon Sep 17 00:00:00 2001
+From: Waqar Ahmed <waqar.17a@gmail.com>
+Date: Thu, 11 Nov 2021 11:14:47 +0500
+Subject: [PATCH] Revert "completion: invoke always"
+
+This reverts commit d116503df2ca1b159c13ae77aac88cdb08408659.
+---
+ src/completion/katecompletionwidget.cpp | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/completion/katecompletionwidget.cpp b/src/completion/katecompletionwidget.cpp
+index 3af1f2b5..73a36423 100644
+--- a/src/completion/katecompletionwidget.cpp
++++ b/src/completion/katecompletionwidget.cpp
+@@ -35,7 +35,6 @@
+ #include <QToolButton>
+
+ const bool hideAutomaticCompletionOnExactMatch = true;
+-const bool invokeCompletionAlways = true;
+
+ // If this is true, the completion-list is navigated up/down when 'tab' is pressed, instead of doing partial completion
+ const bool shellLikeTabCompletion = false;
+@@ -418,9 +417,7 @@ void KateCompletionWidget::startCompletion(const KTextEditor::Range &word,
+ }
+ if (m_completionRanges.contains(model)) {
+ if (*m_completionRanges[model].range == range) {
+- if (!invokeCompletionAlways) {
+- continue; // Leave it running as it is
+- }
++ continue; // Leave it running as it is
+ } else { // delete the range that was used previously
+ KTextEditor::MovingRange *oldRange = m_completionRanges[model].range;
+ // qCDebug(LOG_KTE)<<"removing completion range 2";
+--
+GitLab
+
diff --git a/kde-frameworks/ktexteditor/ktexteditor-5.88.0-r1.ebuild b/kde-frameworks/ktexteditor/ktexteditor-5.88.0-r1.ebuild
new file mode 100644
index 000000000000..65508f4a0393
--- /dev/null
+++ b/kde-frameworks/ktexteditor/ktexteditor-5.88.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing a full text editor component"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+editorconfig git"
+
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/kparts-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/sonnet-${PVCUT}*:5
+ =kde-frameworks/syntax-highlighting-${PVCUT}*:5
+ editorconfig? ( app-text/editorconfig-core-c )
+ git? ( dev-libs/libgit2:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? ( >=kde-frameworks/kservice-${PVCUT}:5 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-revert-invoke-always.patch" # KDE-bug 444883
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package editorconfig EditorConfig)
+ $(cmake_use_find_package git LibGit2)
+ )
+
+ ecm_src_configure
+}