summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-13 19:44:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-14 10:29:23 +0200
commit0b2e5171d3bdaabdfd025bfaee57fcfdd173060e (patch)
tree14c3f803811510b9835083ab41db4d55f2b79905 /kde-frameworks
parentkde-frameworks/knewstuff: 5.97.0 version bump (diff)
downloadgentoo-0b2e5171d3bdaabdfd025bfaee57fcfdd173060e.tar.gz
gentoo-0b2e5171d3bdaabdfd025bfaee57fcfdd173060e.tar.bz2
gentoo-0b2e5171d3bdaabdfd025bfaee57fcfdd173060e.zip
kde-frameworks/knotifyconfig: 5.97.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/knotifyconfig/Manifest1
-rw-r--r--kde-frameworks/knotifyconfig/knotifyconfig-5.97.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/knotifyconfig/Manifest b/kde-frameworks/knotifyconfig/Manifest
index a91848a84f6c..831d082f152c 100644
--- a/kde-frameworks/knotifyconfig/Manifest
+++ b/kde-frameworks/knotifyconfig/Manifest
@@ -1 +1,2 @@
DIST knotifyconfig-5.96.0.tar.xz 87484 BLAKE2B 38358c908c3bd590b04a9802fa9b2694c7db5f92348138f8c81e5a56a014391c56cba0fe8e476fcc8c59d980e31a7b64ccecf564c63bc0f46b0b2ae6c8783303 SHA512 b0f6d8b6d01b4196943c2527e6562c24515ee66da05ad94f1be8178db6a2be42338e68ba15ca2e76dc71014432f7054aff3a969d9ede67938dc67ee6ba5919df
+DIST knotifyconfig-5.97.0.tar.xz 87376 BLAKE2B 375b413b855ccab47965e4958b97ca233485abae4cefb5492b7d4e5d9d16894b9c1defffa4e93bb78a0efa06b2ec3e53895aaf2eeca03571d460c602d41f66e2 SHA512 73118ad313b3ddbbafcf02f2ef8a79ee31b722edd914ae40a53cdd253b708be81832d0a115d1b965d1d3fd887a0f268ddab3b2c72eb89850c29ea9ea5482bf93
diff --git a/kde-frameworks/knotifyconfig/knotifyconfig-5.97.0.ebuild b/kde-frameworks/knotifyconfig/knotifyconfig-5.97.0.ebuild
new file mode 100644
index 000000000000..a1f0b20c7345
--- /dev/null
+++ b/kde-frameworks/knotifyconfig/knotifyconfig-5.97.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for configuring desktop notifications"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="phonon"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( >=media-libs/phonon-4.11.0 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !phonon Canberra)
+ )
+ ecm_src_configure
+}