summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:19:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-13 20:51:06 +0100
commit52d1c83353f4774ecd76c42b8881d9a82416124a (patch)
treef443b7f5d1cfb5efb4b0f82bdf51c521f33745c1 /kde-frameworks/ki18n
parentkde-frameworks/kholidays: 5.88.0 version bump (diff)
downloadgentoo-52d1c83353f4774ecd76c42b8881d9a82416124a.tar.gz
gentoo-52d1c83353f4774ecd76c42b8881d9a82416124a.tar.bz2
gentoo-52d1c83353f4774ecd76c42b8881d9a82416124a.zip
kde-frameworks/ki18n: 5.88.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n')
-rw-r--r--kde-frameworks/ki18n/Manifest1
-rw-r--r--kde-frameworks/ki18n/ki18n-5.88.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/Manifest b/kde-frameworks/ki18n/Manifest
index 32ec7344974c..e9926286dc3e 100644
--- a/kde-frameworks/ki18n/Manifest
+++ b/kde-frameworks/ki18n/Manifest
@@ -1,2 +1,3 @@
DIST ki18n-5.85.0.tar.xz 590384 BLAKE2B 337898b907e673365175a3fd7f122baa156266e60ae47d0f5f7f9afa577c4ed2abfd34d8b2189c162fa4c15e4b726984cf620d699a65b8dfebbeeea99eab0079 SHA512 01053f5715d907eba28daab411880013b9f0305f72d84d1a26edd1aeae6b3f05c1b580ea95aae4de122a57a3bcabb11c4737a82bd51facf8201d584c64708856
DIST ki18n-5.87.0.tar.xz 590996 BLAKE2B fbb24921273a6deadcb943cc30f63e5ea7b39d35ef1ce7e0d2e325471c26b3c4936d712ce4bfcc39fc8194e3cd40164ba70dc2a77d6eb97dcf35beb74b95bf17 SHA512 3b6420de995d6ed64a57934c16334fc48bdd495e81d5b64c15d2403c82fcbab21601d831d9b802b61af64b88c16281a50c8d689069bb3a92467c963cb6e9a0ac
+DIST ki18n-5.88.0.tar.xz 954564 BLAKE2B c482e3d0839c90e5abf73cbbb6e2fb6478bcfff2dc7d8945316c04bece8d278f90ce97868cde2fe9bc2270c17f0aae2e91fbb872a422d6e70278c30dae353cc8 SHA512 7d417a34667ca0e63a49e8d7cc2608028ea66e51adb6f22934a694fda65bb3f858b1e36960b184dcfd919d90107264682bd6426b27cbaba92faf34758668784c
diff --git a/kde-frameworks/ki18n/ki18n-5.88.0.ebuild b/kde-frameworks/ki18n/ki18n-5.88.0.ebuild
new file mode 100644
index 000000000000..5b6f6502c029
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.88.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.57.0-python.patch" )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}