summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-07-06 14:13:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-07-06 14:14:39 +0200
commitf77b1d87c3ec1625a950b58849d5430744040528 (patch)
treefb3fe20d09e13d7bf993801f07272b36275579ea /kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild
parentnet-libs/kdav2: new package (diff)
downloadgentoo-f77b1d87c3ec1625a950b58849d5430744040528.tar.gz
gentoo-f77b1d87c3ec1625a950b58849d5430744040528.tar.bz2
gentoo-f77b1d87c3ec1625a950b58849d5430744040528.zip
kde-frameworks/ki18n: Fix stable L10N build regression
See also: https://phabricator.kde.org/D6331 Upstream commit 77eab970fde3ecbc259d6deff61fce4f360b05a7 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild b/kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild
new file mode 100644
index 000000000000..ef4e14f9f485
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.34.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_qt_dep qtscript)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative)
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-tsfiles.patch" )
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ kde5_src_install
+ python_fix_shebang "${ED}/usr/$(get_libdir)/cmake/KF5I18n/ts-pmap-compile.py"
+}