summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-10 14:42:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-10 18:03:50 +0200
commitecf095f36dd10418d8f4e1b25e2eadb372a50f0e (patch)
tree21242a4621378ce7e777eb192663404e6a477d08 /kde-frameworks/frameworkintegration
parentgames-engines/devilutionx: Adjusted postinst message (diff)
downloadgentoo-ecf095f36dd10418d8f4e1b25e2eadb372a50f0e.tar.gz
gentoo-ecf095f36dd10418d8f4e1b25e2eadb372a50f0e.tar.bz2
gentoo-ecf095f36dd10418d8f4e1b25e2eadb372a50f0e.zip
kde-frameworks/frameworkintegration: 5.75.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.75.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 489879a5520c..2684ca3638ba 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.74.0.tar.xz 1754176 BLAKE2B f325c8362182c066f7fef108a350e9c9378e084c7955e1395fb44918759dbd7e5f55cae037525b286cf9f6b0c67788a766b62bdf737994378b1978a7ef7dd507 SHA512 4bf533b261c149a10ed4b4607f532b57b989f6e130c417a0398216ddbe1b4b3ab964009aa5c021bdc92960f8c25c7f5c66cf8606ed7956b25adfa401d0f08e68
+DIST frameworkintegration-5.75.0.tar.xz 1754740 BLAKE2B 8a3d58fcfc35da8df3b4482cb4550cef7312071d92b168d87555119f124350847d870616b908f24a73f08d03c04bf944b0a9c9c33d29113656e0a2581ced814f SHA512 38c3182d7278ca985acb9f4a9a8c47fa1e7b61a6c23a8285000fd67d1ae4fdc59d2f05f48471ade38c92a35ffb8fafeb4092f46704f3501e2e0dbb7b94d602ea
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.75.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.75.0.ebuild
new file mode 100644
index 000000000000..2aee64430b07
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.75.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}