summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-21 18:45:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-21 19:10:26 +0200
commit9adc3fa6636ede8bbdca20ff1e6362496912413f (patch)
tree8951d4526a761f7ddc9ed014cc4cb1a97769ac4a /kde-apps
parentkde-apps/libksane: 22.04.0 version bump (diff)
downloadgentoo-9adc3fa6636ede8bbdca20ff1e6362496912413f.tar.gz
gentoo-9adc3fa6636ede8bbdca20ff1e6362496912413f.tar.bz2
gentoo-9adc3fa6636ede8bbdca20ff1e6362496912413f.zip
kde-apps/okular: 22.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/okular/Manifest1
-rw-r--r--kde-apps/okular/files/okular-22.04.0-optional-options.patch113
-rw-r--r--kde-apps/okular/okular-22.04.0.ebuild106
3 files changed, 220 insertions, 0 deletions
diff --git a/kde-apps/okular/Manifest b/kde-apps/okular/Manifest
index 5949a30fdc4f..88a72dd56d3d 100644
--- a/kde-apps/okular/Manifest
+++ b/kde-apps/okular/Manifest
@@ -1,2 +1,3 @@
DIST okular-21.08.3.tar.xz 8088712 BLAKE2B 50ded7dba63355a995db869d2b4f6eabd3aad905c1d17cd9b5e51cfd0d082ade838d641aee246c0aabf10d24c7c4704cdae03d2e9499452a1cb3c344b05997da SHA512 50f5e4718ae879932aad411dc6569905c541852f81ecf0e4c1896eb249039311c1360274d051ae3aba05e37dd2ec010844b56e277f52b1cc5326a86f8ecba85d
DIST okular-21.12.3.tar.xz 8150344 BLAKE2B 57661406e352ae5deca610a5c3ab5846449cd3b3cdce4ef4ca55eacf8932e07840b85ebf273ed47c8227789800ddd7e8c2510886e136f7b827d98775e5add52a SHA512 6ead15b1994daba427ba5498636706bbc7341ce468fb36bba62e008e881980ebef22449dcc61f6dc848c7ba95c239709c4106f9f61fb6d92e44e1c11d539360d
+DIST okular-22.04.0.tar.xz 8178256 BLAKE2B 320e92660082b68dcddfb31ba607e455e0025aa1d22b50c36eeaf17b81cd7c489c181360e6a3fc02f02a8496883be3d7b76afd227928c50dc10652f2429204d6 SHA512 884154cdb04062307530313606ba0ffb9eea7e092d83a6b4d39d6925f3368300b47e17b0de04f46ac9547a9890d1658bada80065d33f44b04cadeeaf4239f127
diff --git a/kde-apps/okular/files/okular-22.04.0-optional-options.patch b/kde-apps/okular/files/okular-22.04.0-optional-options.patch
new file mode 100644
index 000000000000..caaf389b670b
--- /dev/null
+++ b/kde-apps/okular/files/okular-22.04.0-optional-options.patch
@@ -0,0 +1,113 @@
+From f29b89d8ac7fcca1cf74462dcc33da24551c924f Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 31 Aug 2021 16:48:42 +0200
+Subject: [PATCH] Make WITH_KWALLET and WITH_KJS proper cmake options
+
+Since I was asked to implement this, might as well make it real options,
+not just limited to ANDROID. Even though optional find_package() call is
+already being used for KF5Purpose as well.
+
+KF5DocTools is not made required more often than not.
+
+See also: https://invent.kde.org/graphics/okular/-/issues/61
+Downstream report: https://bugs.gentoo.org/810958
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 21 ++++++++-------------
+ config-okular.h.cmake | 6 ++++++
+ core/generator.cpp | 1 +
+ core/scripter.cpp | 1 +
+ 4 files changed, 16 insertions(+), 13 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 547671f24..f1e14fa8b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -91,12 +91,9 @@ ecm_setup_qtplugin_macro_names(
+ PACKAGE_SETUP_AUTOMOC_VARIABLES
+ )
+
+-set(optionalComponents)
+-if (ANDROID)
+-# we want to make sure that generally all components are found
+-
+- set(optionalComponents "OPTIONAL_COMPONENTS")
+-endif()
++# we want to make sure that generally all components are found
++option(WITH_KWALLET "Build with desktop-wide storage for password support" ON)
++option(WITH_KJS "Build with scripting support" ON)
+
+ find_package(KF5 ${KF5_REQUIRED_VERSION} REQUIRED COMPONENTS
+ Archive
+@@ -110,21 +107,19 @@ find_package(KF5 ${KF5_REQUIRED_VERSION} REQUIRED COMPONENTS
+ KIO
+ ThreadWeaver
+ WindowSystem
+- ${optionalComponents}
++ OPTIONAL_COMPONENTS
+ DocTools
+- JS
+- Wallet
+ )
+
+ if (BUILD_DESKTOP)
+ find_package(KF5 ${KF5_REQUIRED_VERSION} REQUIRED COMPONENTS Parts Crash IconThemes TextWidgets)
+ endif()
+
+-if(KF5Wallet_FOUND)
+- add_definitions(-DWITH_KWALLET=1)
++if(WITH_KWALLET)
++ find_package(KF5Wallet ${KF5_REQUIRED_VERSION} REQUIRED)
+ endif()
+-if(KF5JS_FOUND)
+- add_definitions(-DWITH_KJS=1)
++if(WITH_KJS)
++ find_package(KF5JS ${KF5_REQUIRED_VERSION} REQUIRED)
+ endif()
+
+ if(NOT WIN32 AND NOT ANDROID)
+diff --git a/config-okular.h.cmake b/config-okular.h.cmake
+index 905aac9cb..00e45f77c 100644
+--- a/config-okular.h.cmake
++++ b/config-okular.h.cmake
+@@ -1,6 +1,12 @@
+ /* Defines if force the use DRM in okular */
+ #define OKULAR_FORCE_DRM ${_OKULAR_FORCE_DRM}
+
++/* Defines if the KJS framework is available */
++#cmakedefine WITH_KJS
++
++/* Defines if the kwallet framework is available */
++#cmakedefine WITH_KWALLET
++
+ /* Defines if the purpose framework is available */
+ #define PURPOSE_FOUND ${PURPOSE_FOUND}
+
+diff --git a/core/generator.cpp b/core/generator.cpp
+index 8360bb32b..0871c17ee 100644
+--- a/core/generator.cpp
++++ b/core/generator.cpp
+@@ -9,6 +9,7 @@
+ */
+
+ #include "generator.h"
++#include "config-okular.h"
+ #include "generator_p.h"
+ #include "observer.h"
+
+diff --git a/core/scripter.cpp b/core/scripter.cpp
+index c60645895..2e6eacc72 100644
+--- a/core/scripter.cpp
++++ b/core/scripter.cpp
+@@ -5,6 +5,7 @@
+ */
+
+ #include "scripter.h"
++#include "config-okular.h"
+
+ #include <QDebug>
+ #include <QFile>
+--
+2.35.1
+
diff --git a/kde-apps/okular/okular-22.04.0.ebuild b/kde-apps/okular/okular-22.04.0.ebuild
new file mode 100644
index 000000000000..bce77f9376d2
--- /dev/null
+++ b/kde-apps/okular/okular-22.04.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Universal document viewer based on KDE Frameworks"
+HOMEPAGE="https://okular.kde.org https://apps.kde.org/okular/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="crypt djvu epub +image-backend markdown mobi +pdf +plucker +postscript qml share speech +tiff"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjs-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/threadweaver-${KFMIN}:5
+ media-libs/freetype
+ >=media-libs/phonon-4.11.0
+ sys-libs/zlib
+ crypt? ( >=kde-frameworks/kwallet-${KFMIN}:5 )
+ djvu? ( app-text/djvu )
+ epub? ( app-text/ebook-tools )
+ image-backend? (
+ >=dev-qt/qtgui-${QTMIN}:5[gif,jpeg,png]
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+ markdown? ( >=app-text/discount-2.2.7-r1 )
+ mobi? ( >=kde-apps/kdegraphics-mobipocket-${PVCUT}:5 )
+ pdf? ( >=app-text/poppler-21.10.0[nss,qt5] )
+ plucker? ( virtual/jpeg:0 )
+ postscript? ( app-text/libspectre )
+ share? ( >=kde-frameworks/purpose-${KFMIN}:5 )
+ speech? ( >=dev-qt/qtspeech-${QTMIN}:5 )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ image-backend? ( >=kde-frameworks/kimageformats-${KFMIN}:5 )
+ qml? (
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-21.11.80-tests.patch" # bug 734138
+ "${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
+ "${FILESDIR}/${P}-optional-options.patch" # bug 810958
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_CHM=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KHtml=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibZip=ON
+ -DOKULAR_UI=$(usex qml "both" "desktop")
+ -DWITH_KWALLET=$(usex crypt)
+ $(cmake_use_find_package djvu DjVuLibre)
+ $(cmake_use_find_package epub EPub)
+ $(cmake_use_find_package image-backend KF5KExiv2)
+ $(cmake_use_find_package markdown Discount)
+ $(cmake_use_find_package mobi QMobipocket)
+ $(cmake_use_find_package pdf Poppler)
+ $(cmake_use_find_package plucker JPEG)
+ $(cmake_use_find_package postscript LibSpectre)
+ $(cmake_use_find_package share KF5Purpose)
+ $(cmake_use_find_package speech Qt5TextToSpeech)
+ $(cmake_use_find_package tiff TIFF)
+ )
+ ecm_src_configure
+}
+
+src_test() {
+ # mainshelltest hangs, chmgeneratortest fails, bug #603116
+ # parttest hangs, bug #641728, annotationtoolbartest fails, KDE-Bug #429640
+ local myctestargs=(
+ -E "(mainshelltest|chmgeneratortest|parttest|annotationtoolbartest)"
+ )
+
+ ecm_src_test
+}