summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:55:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:58:19 +0100
commitff68a61d7cd4786f56bed62410f9206e588e8d8e (patch)
tree69313c252a0aed267809ad3a0d7f31c5c10177a3 /kde-apps/print-manager
parentdev-php/pecl-yaz: amd64 stable wrt bug #667068 (diff)
downloadgentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.gz
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.bz2
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.zip
kde-apps: Add KDE Applications 18.12.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-18.12.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 257386b27945..8df1de9d2124 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-18.08.3.tar.xz 238796 BLAKE2B f3fe67bb2a6b7f2e05b7ed8934ba491a829eff842fdd1f76af3cc376e679826e6ae1f332242d278215828b4842a0bf85b6e22d5b3ffb03d61f01c5f575cfa0d1 SHA512 0727f5e125ac2198276a92acfd881077647ab082b5edc9c4e5211f53dccd19e12b9b6934fd696424e029d5f7de373a194f9c302f587fb0c80af42526cd4a04ad
+DIST print-manager-18.12.0.tar.xz 238876 BLAKE2B 9c80d1af88eb40745774291b5f75175e5efecbbfe8979848b660cf5b8ead44d3b1d01515258ff863434517ca4107712a2e0b47c522027e30a5989b71b477505f SHA512 66652e0644b75bbf16ffcc963fa272901b9130e96998e93c67d6c6914ffe28be581756b7e6b459d0477ed15a7a0ba9f7f6cd1c7938d4124a0443770619cc6541
diff --git a/kde-apps/print-manager/print-manager-18.12.0.ebuild b/kde-apps/print-manager/print-manager-18.12.0.ebuild
new file mode 100644
index 000000000000..2339cfc9baff
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-18.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ if ! use gtk ; then
+ ewarn
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ ewarn
+ fi
+}