summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-03 22:36:52 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-01-05 04:32:10 +1100
commit7df7309afdd24364b3cbe1d0c2fd29af243ba0c8 (patch)
treeb135dfbf75dd5f75de97f6298d4e6aa01d1790b2 /kde-apps/kde-wallpapers
parentmedia-libs/taglib: version bump (diff)
downloadgentoo-7df7309afdd24364b3cbe1d0c2fd29af243ba0c8.tar.gz
gentoo-7df7309afdd24364b3cbe1d0c2fd29af243ba0c8.tar.bz2
gentoo-7df7309afdd24364b3cbe1d0c2fd29af243ba0c8.zip
kde-apps/kde-wallpapers: Add transitional kde4-based ebuild w/ USE=minimal
Not having a stabilised non-conflicting kde-wallpapers release is creating a needless block on a future plasma-5 upgrade. Package-Manager: portage-2.2.26
Diffstat (limited to 'kde-apps/kde-wallpapers')
-rw-r--r--kde-apps/kde-wallpapers/kde-wallpapers-15.08.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-apps/kde-wallpapers/kde-wallpapers-15.08.3.ebuild b/kde-apps/kde-wallpapers/kde-wallpapers-15.08.3.ebuild
new file mode 100644
index 000000000000..552c0005e9c5
--- /dev/null
+++ b/kde-apps/kde-wallpapers/kde-wallpapers-15.08.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-wallpapers"
+inherit kde4-base
+
+DESCRIPTION="KDE wallpapers"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+src_configure() {
+ local mycmakeargs=( -DWALLPAPER_INSTALL_DIR="${EPREFIX}/usr/share/wallpapers" )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use minimal ; then
+ rm -r "${ED}"usr/share/wallpapers/Autumn || die
+ fi
+}