summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-01 11:08:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 18:08:35 +0200
commitc956ebc489ff0f590908a8f11693d01a13122c52 (patch)
treea911094650b3bb79db10d249185a659ca304140d /kde-apps/kde-l10n
parentkde-apps/kde4-l10n: Migrate to L10N (diff)
downloadgentoo-c956ebc489ff0f590908a8f11693d01a13122c52.tar.gz
gentoo-c956ebc489ff0f590908a8f11693d01a13122c52.tar.bz2
gentoo-c956ebc489ff0f590908a8f11693d01a13122c52.zip
kde-apps/kde-l10n: Migrate to L10N
Diffstat (limited to 'kde-apps/kde-l10n')
-rw-r--r--kde-apps/kde-l10n/kde-l10n-15.12.3-r2.ebuild22
-rw-r--r--kde-apps/kde-l10n/kde-l10n-16.04.2.ebuild12
2 files changed, 15 insertions, 19 deletions
diff --git a/kde-apps/kde-l10n/kde-l10n-15.12.3-r2.ebuild b/kde-apps/kde-l10n/kde-l10n-15.12.3-r2.ebuild
index 41c76fff8853..c6b07dd6e51a 100644
--- a/kde-apps/kde-l10n/kde-l10n-15.12.3-r2.ebuild
+++ b/kde-apps/kde-l10n/kde-l10n-15.12.3-r2.ebuild
@@ -34,12 +34,12 @@ MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru
sk sl sr sv tr ug uk wa zh_CN zh_TW"
-IUSE="$(printf 'linguas_%s ' ${MY_LANGS})"
+IUSE="$(printf 'l10n_%s ' ${MY_LANGS//[_@]/-})"
URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI="mirror://kde/stable/plasma/${KHC_PV}/${KHC}.tar.xz"
for my_lang in ${MY_LANGS} ; do
- SRC_URI="${SRC_URI} linguas_${my_lang}? ( ${URI_BASE}/${PN}-${my_lang}-${PV}.tar.xz )"
+ SRC_URI="${SRC_URI} l10n_${my_lang//[_@]/-}? ( ${URI_BASE}/${PN}-${my_lang}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -47,12 +47,10 @@ S="${WORKDIR}"
pkg_setup() {
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
MULTIBUILD_VARIANTS=( l10n khelpcenter-l10n )
@@ -75,9 +73,9 @@ src_unpack() {
src_prepare() {
default
- [[ ${LINGUAS} = "" ]] && return
+ [[ ${L10N} = "" ]] && return
- # add all linguas to cmake
+ # add all l10n to cmake
cat <<-EOF > CMakeLists.txt || die
project(kde-l10n)
cmake_minimum_required(VERSION 2.8.12)
@@ -100,7 +98,7 @@ EOF
if [[ -d ${KHC}/po ]] ; then
pushd ${KHC}/po > /dev/null || die
for lang in *; do
- if [[ -d ${lang} ]] && ! has ${lang} ${LINGUAS} ; then
+ if [[ -d ${lang} ]] && ! has "${lang/[@_]/-}" ${L10N} ; then
rm -r ${lang} || die
if [[ -e CMakeLists.txt ]] ; then
cmake_comment_add_subdirectory ${lang}
@@ -148,15 +146,15 @@ src_configure() {
fi
kde5_src_configure
}
- [[ ${LINGUAS} != "" ]] && multibuild_foreach_variant myconfigure
+ [[ ${L10N} != "" ]] && multibuild_foreach_variant myconfigure
}
src_compile() {
- [[ ${LINGUAS} != "" ]] && multibuild_foreach_variant kde5_src_compile
+ [[ ${L10N} != "" ]] && multibuild_foreach_variant kde5_src_compile
}
src_test() { :; }
src_install() {
- [[ ${LINGUAS} != "" ]] && multibuild_foreach_variant kde5_src_install
+ [[ ${L10N} != "" ]] && multibuild_foreach_variant kde5_src_install
}
diff --git a/kde-apps/kde-l10n/kde-l10n-16.04.2.ebuild b/kde-apps/kde-l10n/kde-l10n-16.04.2.ebuild
index b57d3e05964f..af44a9147df7 100644
--- a/kde-apps/kde-l10n/kde-l10n-16.04.2.ebuild
+++ b/kde-apps/kde-l10n/kde-l10n-16.04.2.ebuild
@@ -31,12 +31,12 @@ MY_LANGS="ar ast bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga
gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro
ru sk sl sr sv tr ug uk wa zh_CN zh_TW"
-IUSE="$(printf 'linguas_%s ' ${MY_LANGS})"
+IUSE="$(printf 'l10n_%s ' ${MY_LANGS//[_@]/-})"
URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""
for my_lang in ${MY_LANGS} ; do
- SRC_URI="${SRC_URI} linguas_${my_lang}? ( ${URI_BASE}/${PN}-${my_lang}-${PV}.tar.xz )"
+ SRC_URI="${SRC_URI} l10n_${my_lang//[_@]/-}? ( ${URI_BASE}/${PN}-${my_lang}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -44,12 +44,10 @@ S="${WORKDIR}"
pkg_setup() {
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
[[ -n ${A} ]] && kde5_pkg_setup
@@ -67,7 +65,7 @@ src_prepare() {
default
[[ -n ${A} ]] || return
- # add all linguas to cmake
+ # add all l10n to cmake
cat <<-EOF > CMakeLists.txt || die
project(kde-l10n)
cmake_minimum_required(VERSION 2.8.12)