summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/dolphin-plugins
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/dolphin-plugins')
-rw-r--r--kde-apps/dolphin-plugins/Manifest1
-rw-r--r--kde-apps/dolphin-plugins/dolphin-plugins-17.12.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins/Manifest b/kde-apps/dolphin-plugins/Manifest
index e8d97a3b6eb1..0ee7f65ab020 100644
--- a/kde-apps/dolphin-plugins/Manifest
+++ b/kde-apps/dolphin-plugins/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-17.08.3.tar.xz 187084 BLAKE2B abe392d68e622c8cc02aaae31d71ffa28bc19544e7b9306ae3cfcc73a18ae9d4b453626274158d94d52140bff16e39c987a68423d4e24dfcac38efcab65cefef SHA512 49bd9b9059a129e9276d2cc216679abbdec595a98aa3ee950164fafcef30a2206b18e3b7487a6665aa3da6c643d92017309fedcfad0caacdadd7433126690970
+DIST dolphin-plugins-17.12.0.tar.xz 187108 BLAKE2B 828bc8e728b28b8ba20f664055e090809b0901dc3444f6d1a1c4bdf79d65b8059cf73b379acd23a5d6eec85ebb59f278b2f7d797962777cf0b12803cbb9f76bc SHA512 551406733c97d0a4a0bb4d0567ce0351c64c33db501afad2c7ab49436d67e512c5d3ad34e7f5544765c09aba853ae31a48c1eeac81722f83485d91b41c22a586
diff --git a/kde-apps/dolphin-plugins/dolphin-plugins-17.12.0.ebuild b/kde-apps/dolphin-plugins/dolphin-plugins-17.12.0.ebuild
new file mode 100644
index 000000000000..a370260ca5a1
--- /dev/null
+++ b/kde-apps/dolphin-plugins/dolphin-plugins-17.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="false"
+inherit kde5
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar dropbox git mercurial subversion"
+
+# FIXME: required in root CMakeLists.txt, but:
+# kdelibs4support only required by git?
+# kxmlgui, qtnetwork only required by dropbox?
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ git? (
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep ktextwidgets)
+ )
+ mercurial? (
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ dropbox? ( net-misc/dropbox-cli )
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_bazaar=$(usex bazaar)
+ -DBUILD_dropbox=$(usex dropbox)
+ -DBUILD_git=$(usex git)
+ -DBUILD_hg=$(usex mercurial)
+ -DBUILD_svn=$(usex subversion)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ { use bazaar || use dropbox || use git || use subversion || use mercurial; } && kde5_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use dropbox && ! use git && ! use subversion && ! use mercurial; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}