summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-13 22:13:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-13 22:40:16 +0200
commit5c235227fb9a8de49d4a99cb21c34e8d37e4e522 (patch)
tree1b519325caa031e1d4a4f78a746daf73097d6211 /gui-apps
parentdev-libs/mpfr: add 4.2.0_rc1 (unkeyworded) (diff)
downloadgentoo-5c235227fb9a8de49d4a99cb21c34e8d37e4e522.tar.gz
gentoo-5c235227fb9a8de49d4a99cb21c34e8d37e4e522.tar.bz2
gentoo-5c235227fb9a8de49d4a99cb21c34e8d37e4e522.zip
gui-apps/slurp: add 1.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/slurp/Manifest1
-rw-r--r--gui-apps/slurp/slurp-1.4.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
index 46a2254a9872..256b44c3ee57 100644
--- a/gui-apps/slurp/Manifest
+++ b/gui-apps/slurp/Manifest
@@ -1 +1,2 @@
DIST slurp-1.3.2.tar.gz 17734 BLAKE2B 42795f1927742ce9606c685a49f2fb395905c875b50b50b60b68bf129d3c6743278a0eeaed72b94921dd65bd4ca4c078c24c693029cff84dbcbe20165242653c SHA512 9e7f9e4b46095fce5dcc05f8d04b5e576771d15080a0ec451a8a5df681d5ab818cb4d5284a74e1650f775e2d05ca32d66551d8e333d6002827c8b60b12d6bb28
+DIST slurp-1.4.0.tar.gz 18575 BLAKE2B b54a5fe34f35a6a4eefe021a5d5919ae6369c24cfe4906e13ddaf7abc173fad4dc184b211bbadcd09a2a20768e91bbc7199d5e1f29287e9f3fd49b58b294d747 SHA512 deabdc77890a3078d977533318aad6aff9478e32c95e7968483b82534bd52055dce11a531132212ac8966097dad9c6c5e7ad520a374ace85d0ec713df1505d5a
diff --git a/gui-apps/slurp/slurp-1.4.0.ebuild b/gui-apps/slurp/slurp-1.4.0.ebuild
new file mode 100644
index 000000000000..745c8a09bafe
--- /dev/null
+++ b/gui-apps/slurp/slurp-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output"
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}