summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-06-08 07:23:34 -0300
committerMatt Turner <mattst88@gentoo.org>2023-06-08 19:39:05 -0400
commitb76f49b1d56f8be7c7d0c7e21e76ca46a62f24fe (patch)
treecb37583c7c8cf8246d3a563d43fec743b83aadd9 /gnome-extra
parentgui-libs/gtksourceview: Raise test timeout multiplier (diff)
downloadgentoo-b76f49b1d56f8be7c7d0c7e21e76ca46a62f24fe.tar.gz
gentoo-b76f49b1d56f8be7c7d0c7e21e76ca46a62f24fe.tar.bz2
gentoo-b76f49b1d56f8be7c7d0c7e21e76ca46a62f24fe.zip
gnome-extra/zenity: Version bump to 3.99.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31353 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.99.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 91d7dedb8b0c..55998161f7ea 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,2 +1,3 @@
DIST zenity-3.44.0.tar.xz 3096684 BLAKE2B bd6cb333e30ca675bd6d49a8117fc81a8d5ffe2870b9d78f897f292b827849cfaee7d92d36ebc9dc784041400b221cca715d40878be0bb2f5aa47ccbf9c10965 SHA512 806fff8f239dfa5da32e75bbc1fc3a6dc50b49ea8e6ca64cead9dd40adfe4741237c25ae5caaac1997ec7f274e9379b6607d254caf8a509aa01f3eba03cb3e7c
DIST zenity-3.92.0.tar.xz 3081408 BLAKE2B 1d7da29a52013104cee35e1ac95823e046c391653d71a30f287bc6f330edf4b5f9d1c1d4fddb67e1447750569cc46810c49871b7f263c88ec6d6b7209bfecc6b SHA512 0e28b5fa60736210ee474ee483bd98b63f17c0d815dc6050532e82bda7d82b560f5227e4882fa6c969352d9e48d19c8addf5587acac8eac8f0fc9ac185edaf76
+DIST zenity-3.99.0.tar.xz 3084896 BLAKE2B 71a6848cb2684e71eb8bb8b5ca57ad0c602b58326f2426542774e4806f4ea9929880810f3e4cd43e938554a9905d3381712b62f2cb2b0bfb137d6a47bb004904 SHA512 65820dd9f5e60dad14867dc584ac4a2d43f6c259c4eccd021c76f2deb4206a29de17db4eb8a911fff12243a594b624c1aa3781087bcd41308c4ea6c0dc919633
diff --git a/gnome-extra/zenity/zenity-3.99.0.ebuild b/gnome-extra/zenity/zenity-3.99.0.ebuild
new file mode 100644
index 000000000000..4b872f4ad496
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.99.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}