summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-06-29 19:47:40 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-06 10:54:56 -0400
commit0527f626fd35dc9c3d7b88fb9d4b089a93d1ea70 (patch)
treea61938b975770616efa4c4fba5ab60e1b2bd1fb9 /gnome-extra
parentapp-text/poppler: add 23.07.0 (diff)
downloadgentoo-0527f626fd35dc9c3d7b88fb9d4b089a93d1ea70.tar.gz
gentoo-0527f626fd35dc9c3d7b88fb9d4b089a93d1ea70.tar.bz2
gentoo-0527f626fd35dc9c3d7b88fb9d4b089a93d1ea70.zip
gnome-extra/gnome-system-monitor: Version bump to 45_alpha
Closes: https://bugs.gentoo.org/850085 Closes: https://github.com/gentoo/gentoo/pull/31672 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-45_alpha.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index 8dec148a6d31..f5a57e89790f 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-44.0.tar.xz 1012688 BLAKE2B b9e537ac865c31e0aa05958f067181bf3ef73e4997e818ec4d5d61da65954e910c908901ed55cceac447798d092944a01999fc37f38c7ce51590efedf7f12a85 SHA512 052dcdc927ad53ea601f1f3da6a921fe21b04f69aaa8b75a5096fdcdac5706391180c476b5c87a98012fa7b5dc6c5c43b8c88c30a38b12868c4188020e8ec3b8
+DIST gnome-system-monitor-45.alpha.tar.xz 1013176 BLAKE2B f900ce7d82777b8ce8b0d5ee6b35590f4ac277f0d7b2e125622ea89aaf639138782ecaabedb310cf705d5331a4be5e01d22a08bb9bf20f5cae6d7d687961ce41 SHA512 7bf4f37ac207d2c04f66eb54d6ef36c971d8667bf1cded9e34aa46f203acd7516e4406b4d100a3aa99ddb39d52a17be88e8d4463355b72e2a36a9459f87c7b75
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-45_alpha.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-45_alpha.ebuild
new file mode 100644
index 000000000000..d9c9360329f7
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-45_alpha.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)?]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/atkmm-2.28:0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gui-libs/libhandy-1.5.0:1
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}